wiki:OSG-CE
Last modified 8 years ago Last modified on 02/21/12 14:31:10

How To Create a Virtual Test ROCKS Linux Cluster


Step One - Virtual Machine Setup

This document assumes use of VMWare on OSX Lion. (Other virtualization techniques and OS may require different settings.)

  1. Create one VM for the ROCKS Head Node or Front End and "n" number VM's for each compute element, storage element, etc. (the more VMs you make the more RAM you will need for simultaneous usage)
  2. In each VM accept defaults except for following:

Type - RHEL 5 64 bit Sound - disable USB - Disable RAM - 1024 MB (at least. if not install will most likely fail) Set startup device to CD/DVD

  1. Front End Network VM settings. The Rocks Frontend must have 2 interfaces. One for public facing (internet) access and One for internal cluster nodes networking.

Go to the network settings for the front end virtual machine. In VMWare parlance you create one network as Host only "Create a private network available only to Mac (Host Only)". This is the internal interface. Create Public interface by selecting the "+" and adding new network device. Choose "Connect directly to the physical network (Bridged) Using: Ethernet " (or whatever your primary connection is on the Mac)

  1. Node Network VM settings. You only need one interface. Set it to "Create a private network available only to Mac (Host Only)" as above.
  2. Insert Rocks DVD or change CD/DVD settings to load the ROCKS iso if you dont have a burned disc image.
  3. Start Frontend VM
  4. Type "build" when prompted
  5. Select All required rolls EXCEPT OS
  6. Click next
  7. Go back into VMWare settings for the current VM under "Cd's and DVD's"
  8. Change main cd/dvd image to CentOS dvd iso 1 (or just swap disc if you have burned it)
  9. Click Additional CD/DVD based rolls.
  10. CentOS will be read as "Final" in the roll name. (5.4.3 will be the version listed. This is ROCKS not CentOS, so ignore)
  11. Click Next and fill out all the remaining Identification, Network, Partitioning info. Identification - Self explanatory. The only required part is FQDN. (for example rockvmfe.uabgrid.uab.edu) The installer will prompt you if isn't a FQDN. Also make sure no underscore character are used as it will break DNS server on the frontend without warning. Network - Accept default for internal network unless is conflicts with your environment. Provide proper static IP, Netmask, DNS and Gateway for public interface just as you would for any linux install. Partitioning - Accept auto partitioning....its a VM after all. If you require or want manual partitioning, please do so here.
  12. Build will start and copy CentOS to ROCKS frontend.
  13. When this is done you will be prompted to insert ROCKS dvd. Once again swap image on the main CD/DVD to rocks in VMWare settings (or actual disc if using DVD).
  14. Install continues until complete.
  15. Once install is done dont forget to unmap image from CD/DVD and/or change startup device from CD/DVD to Hard disk.

Open Science Grid Software Installation and Verification

What follows is a daily diary of progress towards goal of implementing OSG stack in ROCKS Test Cluster. Once complete I will present in a more step-oriented, comprehensive fashion.


10:02 CST 17, January 2012

During process of editing the config.ini in the virtual data toolkit it was discovered that rocks DNS will not start if your hostname has an "_" underscore character in the hostname. This causes the configure-vdt script to fail and necessitates a complete rebuild of rocks FE. This is a HUGE weakness in the rocks platform. hostname changes should not require rebuilding the system. currently rebuilding rocks FE.

Rocks rebuilt with frontend hostname now set to rocksvmfe. DNS is functioning:

[root@rockvmfe ~]# ps -ef|grep named
named     2815     1  0 10:15 ?        00:00:00 /usr/sbin/named -u named
root     11349 11238  0 10:20 pts/1    00:00:00 grep named

Proceeding with RPM based install instead of PACMAN.

Also rebuilding Compute nodes in preparation for RPM based OSG install.

10:57 AM CST

Oh wow....guess what. I have to do another Rocks rebuild to get CentOS repos setup properly so that I can install yum-priorities plugin. EPIC Fail

[root@rockvmfe ~]# yum install yum-priorities
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * epel: www.gtlib.gatech.edu
Setting up Install Process
No package yum-priorities available.
Nothing to do

(Also upgraded to Rocks 5.4.3 during this procedure.) Thanks to Mike Hanby here is the proper procedure. You have to include CentOS as the "os" roll during Rocks FE Install.

  1. Download CentOS DVD iso
  2. Boot from Rocks 5.4.3 ISO
  3. Type "build"
  4. Select All required rolls EXCEPT OS
  5. Click next
  6. Go into VMWare settings for the current VM under "Cd's and DVD's"
  7. Change main cd/dvd image to CentOS dvd iso 1 (or just swap disc if you have burned it)
  8. Click Additional CD/DVD based rolls.
  9. CentOS will be read as "Final" in the roll name. (5.4.3 will be the version listed. This is ROCKS not CentOS, so ignore)
  10. Click Next and fill out all the remaining CA, Network, Partitioning info.
  11. Build will start and copy CentOS to ROCKS frontend.
  12. When this is done you will be prompted to insert ROCKS dvd. Once again swap image on the main CD/DVD to rocks in VMWare settings (or actual disc if using DVD).
  13. Install continues...

1:48 PM CST

W00T! Thanks to Mike's advice yum-priorities plugin and CentOS repos are correct now!

root@rocksvmfe ~]# yum install yum-priorities
Rocks-5.4.3                                                                                                                  | 1.1 kB     00:00     
Rocks-5.4.3/primary                                                                                                          | 1.3 MB     00:00     
Rocks-5.4.3                                                                                                                               3779/3779
epel                                                                                                                         | 3.7 kB     00:00     
epel/primary_db                                                                                                              | 3.9 MB     00:06     
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package yum-priorities.noarch 0:1.1.16-16.el5.centos set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

====================================================================================================================================================
 Package                             Arch                        Version                                     Repository                        Size
====================================================================================================================================================
Installing:
 yum-priorities                      noarch                      1.1.16-16.el5.centos                        Rocks-5.4.3                       14 k

Transaction Summary
====================================================================================================================================================
Install       1 Package(s)
Upgrade       0 Package(s)

Total download size: 14 k
Downloading Packages:
yum-priorities-1.1.16-16.el5.centos.noarch.rpm                                                                               |  14 kB     00:00     
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing     : yum-priorities                                                                                                               1/1 

Installed:
  yum-priorities.noarch 0:1.1.16-16.el5.centos                                                                                                      

Complete!
[root@rocksvmfe ~]#


January 18, 2012

Continuing OSG Install. Overview of installation intructions for OSG 3.0 RPM can be found https://twiki.grid.iu.edu/bin/view/Documentation/Release3/InstallComputeElement

First Step for us will be installing DOE/SuraGrid Cert. I have DOE Cert requested back in October 2011 and its installed on my OSX workstation. Just need to export it and get it over to rocks.... Entered ATLAB ticket #228 https://trac.uabgrid.uab.edu/atlab/ticket/288 for opinions


Daily Notes To add back in as needed!:

Some old documentation for Globus settings that we used in the past. Should be helpful in making configuration decisions during install:

http://uabgrid.uab.edu/node/28

One item not covered in the install docs is that you have to have run at least one batch job through the Sun Grid Engine to complete the CE SGE portion. This creates all the proper log files that are necessary to complete the CE installation.


Jan 23, 2012

After speaking with John Paul it appears a host cert is needed not a personal cert. Proceeding with install of OSG repo and certs packages from OSG.

rpm -Uvh http://repo.grid.iu.edu/osg-release-latest.rpm

yum install osg-ca-certs

yum install osg-cert-scripts

cert-request -ou s -dir . -label host.opensciencegrid.org


cert-request returns an error on Rocks 5.4.3 about missing perl module LWP/UserAgent.pm . Cannot find RPM through yum or rpm search. Taking it Old School.

perl -MCPAN -e 'install LWP::UserAgent'

epic fail

[root@rocksvmfe ~]# perl -MCPAN -e 'install LWP::UserAgent'
Can't locate object method "install" via package "LWP::UserAgent" at -e line 1.

going to try and install entire LWP::Bundle!

 perl -MCPAN -e 'install Bundle::LWP'

accept the defaults along the way and go grab a coffee.... 5 minutes later it is complete. Running cert request again.

A lot of input selecting and entering of info later I get. \

You must agree to abide by the DOEGrids policies,
at http://www.doegrids.org/Docs/CP-CPS.pdf
and you assert that you are authorized to request and install this
certificate on the specified host.
Do you agree (y,N): y
Error: 501 Protocol scheme 'https' is not supported (LWP::Protocol::https not installed)
can't open /tmp/response.27989.html No such file or directory

DOH!!!! Seriously?

perl -MCPAN -e 'install LWP::Protocol::https'

And after several network failures to OSG...

cert-request -ou s -dir . -label host.opensciencegrid.org
....
....
....<yada yada yada>
....
You must agree to abide by the DOEGrids policies,
at http://www.doegrids.org/Docs/CP-CPS.pdf
and you assert that you are authorized to request and install this
certificate on the specified host.
Do you agree (y,N): y

Your Certificate Request has been successfully submitted
Your Certificate Request id: 82550 

	You will receive a notification email from the CA when your certificate
	has been issued. Please disregard the instructions to download your
	certificate though a web browser and use the cert-retrieve script instead.

Success

UPDATE: 2012-02-08 - jpr - This issue has been reported upstream and can be tracked via OSG software bug 523.


January 27, 2012

So obviously not success. The cert never arrived. John-Paul checked with some people he knows at OSG and it turns out the syntax of the example to the cert-request comman was incorrect. The host address at the end needs to be your own hostname FQDN. I am rerunning. Here is the FULL output. Note SURAgrid is not listed as a VO.

UPDATE: 2012-02-08 - jpr - The OSG documentation has been updated to clarify that the site's CE hostname should be used as input to the cert-request command.

[root@rocksvmfe ~]# cert-request -ou s -dir . -label rocksvmfe.uabgrid.uab.edu
checking CertLib version, V2-7,  This is the latest version, released 18 May 2009.
Processing OU=Services request.
Give reason (1 line) you qualify for certificate, such as
  member of CMS experiment    or
  collaborating with Condor team,  etc.
 reason: Testing OSG CE Integration for UAB
input server administrator's name: Bill Bradley
input full hostname: rocksvmfe.uabgrid.uab.edu
Generating a 2048 bit RSA private key
...........................................................................................................................................................................................................................................+++
..........................+++
writing new private key to './rocksvmfe.uabgrid.uab.edukey.pem'
-----
input your email address: billb@uab.edu
input your complete phone number: 205-934-3908
Choose a registration authority to which you are affiliated.
If nothing else applies, pick OSG.
_Enter__this____for this registration authority
	ANL	 Argonne National Lab
	ESG	 Earth System Grid
	ESnet	 DOE Science network
	FNAL	 Fermilab certificates
	FusionGRID	 National Fusion Grid Project
	LBNL	 Berkeley Lab
	LCG	 LHC Computing Grid
	NERSC	 computer center, see www.nersc.gov
	ORNL	 Oak Ridge National Lab
	OSG	 Open Science Grid (choose this if nothing else applies)
	Philips	 Philips Research U.S.
	PNNL	 Pacific Northwest National Lab
(choose from left column): OSG
osg
OSG
Choose a virtual organization under your OSG affiliation:
  ATLAS:	United States ATLAS Collaboration
  BNL:	Brookhaven lab researchers
  CDF:	Collider Detector at Fermilab
  CIGI:	CyberInfrastructure and Geospatial Information Laboratory
  CMS:	Compact Muon Solenoid
  CompBioGrid:	CompBioGrid
  DES:	Dark Energy Survey
  DOSAR:	Distributed Organization for Scientific and Academic Research
  DZero:	D0 Experiment at Fermilab
  Engage:	Engagement
  Fermilab:	Fermi National Accelerator Center
  FermilabAccelerator:	Fermilab/Accelerator
  FermilabAstro:	Fermilab/Astro
  FermilabCdms:	Fermilab/Cdms
  FermilabGrid:	fermilab VO grid group
  FermilabHypercp:	Fermilab/Hypercp
  FermilabKTeV:	Fermilab/KTeV
  FermilabMinerva:	Fermilab/Minerva
  FermilabMiniboone:	Fermilab/Miniboone
  FermilabMinos:	Fermilab/Minos
  FermilabMipp:	Fermilab/Mipp
  FermilabNova:	Fermilab/Nova
  FermilabNumi:	Fermilab/Numi
  FermilabPatriot:	Fermilab/Patriot
  FermilabTest:	Fermilab/Test
  FermilabTheory:	Fermilab/Theory
  Geant4:	Geant4 Software Toolkit
  GLOW:	Grid Laboratory of Wisconsin
  GPN:	Great Plains Network
  GRASE:	Group Researching Advances in Software Engineering at University of New York at Buffalo
  GROW:	Grid Research and Education Group at Iowa
  GUGrid:	Georgetown University Grid
  I2u2:	Interactions in Understanding the Universe Initiative
  IceCube:	IceCube Neutrino Telescope
  ILC:	International Linear Collider
  JLab:	Jefferson Lab researchers
  LIGO:	Laser Interferometer Gravitational-Wave Observatory
  Mariachi:	Mixed Apparatus for Radar Investigation of Cosmic-rays of  High Ionization Experiment
  MIS:	OSG Monitoring Information System
  NanoHUB:	nanoHUB Network for Computational Nanotechnology (NCN)
  NWICG:	Northwest Indiana Computational Grid
  NYSGRID:	NYSGRID
  Ops:	WLCG Operations Group
  OSG:	Open Science Grid
  OSGEDU:	OSG Education Activity
  SBGrid:	Structural Biology Grid
  SDSS:	Sloan Digital Sky Survey
  SLAC:	SLAC National Accelerator Laboratory researchers
  STAR:	Solenoidal Tracker at RHIC
(Choose from left column; pick osg if nothing else applies): OSG
OSG:OSG
You must agree to abide by the DOEGrids policies,
at http://www.doegrids.org/Docs/CP-CPS.pdf
and you assert that you are authorized to request and install this
certificate on the specified host.
Do you agree (y,N): y

Your Certificate Request has been successfully submitted
Your Certificate Request id: 82801 

	You will receive a notification email from the CA when your certificate
	has been issued. Please disregard the instructions to download your
	certificate though a web browser and use the cert-retrieve script instead.
 

January 31, 2012

Finally recieved and isntalled host certificate. Installation procedure different than documentation @ https://twiki.grid.iu.edu/bin/view/Documentation/Release3/GetHostServiceCertificates#Install_the_CA_Certificates_A_qu

Instead run cert-retrieve as instructred to in email from OSG/DOE

Your Service/Host certificate request has been processed successfully.
SubjectDN= CN=rocksvmfe.uabgrid.uab.edu,OU=Services,DC=doegrids,DC=org
notAfter= Jan 30, 2013 8:12:22 AM
notBefore= Jan 31, 2012 8:12:22 AM
Serial Number= 0x10105

Complete details can be found here:
https://pki1.doegrids.org:443/displayBySerial?op=displayBySerial&serialNumber=65797


Your certificate requested using the script interface, request id: 82801,
has been approved and is available for download.  To retrieve your
certificate, execute the command below using the same working
directory from which the request was made.

# cert-retrieve -serialnum 65797 

If you requested the certificate with optional parameters specifying
labelling or a non-standard directory for storing your certificate
see the cert-retrieve and cert-request man pages for additional
explanation.
# cert-retrieve -help
# cert-request -help


and here is what i ran

root@rocksvmfe ~]cert-retrieve -serialnum 65797 
checking CertLib version, V2-7,  This is the latest version, released 18 May 2009.
 using CA doegrids
Using URL https://pki1.doegrids.org/displayBySerial?op=displayBySerial&serialNumber=65797
input pathname of keyfile that was generated at the time the request was made: 
/root/rocksvmfe.uabgrid.uab.edukey.pem
Checking that the certificate and /root/rocksvmfe.uabgrid.uab.edukey.pem match
writing RSA key
/root/.globus/hostcert.pem and /root/.globus/hostkey.pem now contain your new credential

Next you have to copy the host key and cert to /etc/grid-security/ *Notice the key and cert were moved to .globus/ in previous step. This differs from install instruction of OSG.

cp .globus/hostcert.pem /etc/grid-security/
cp .globus/hostkey.pem /etc/grid-security/
chmod 444 /etc/grid-security/hostcert.pem
chmod 400 /etc/grid-security/hostkey.pem

You should verify the key just to make sure

[root@rocksvmfe ~]# openssl x509 -in /etc/grid-security/hostcert.pem -subject -issuer -dates -noout
subject= /DC=org/DC=doegrids/OU=Services/CN=rocksvmfe.uabgrid.uab.edu
issuer= /DC=org/DC=DOEGrids/OU=Certificate Authorities/CN=DOEGrids CA 1
notBefore=Jan 31 16:12:22 2012 GMT
notAfter=Jan 30 16:12:22 2013 GMT

Batch Engine Installation

Your cluster needs a batch engine for OSG to be able to deliver jobs. You probably already havea batch system installed since you have to distriubute work someway. @UAB we are currently using Sun Grid Engine. ROCKS already installs SGE for you on your head node and compute elements, so you dont need to install via RPM as per instructions @OSG. However you do need to trick install of CE by installing the dummy RPM package. This is detailed in the instruction DOCS but basically:

[root@rocksvmfe ~]# yum install empty-gridengine
Rocks-5.4.3                                                                                                                     | 1.1 kB     00:00     
epel                                                                                                                            | 3.7 kB     00:00     
epel/primary_db                                                                                                                 | 3.7 MB     00:02     
osg                                                                                                                             | 1.9 kB     00:00     
osg/primary_db                                                                                                                  | 608 kB     00:00     
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package empty-gridengine.noarch 0:1.0-1 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=======================================================================================================================================================
 Package                                     Arch                              Version                            Repository                      Size
=======================================================================================================================================================
Installing:
 empty-gridengine                            noarch                            1.0-1                              osg                            1.7 k

Transaction Summary
=======================================================================================================================================================
Install       1 Package(s)
Upgrade       0 Package(s)

Total download size: 1.7 k
Downloading Packages:
empty-gridengine-1.0-1.noarch.rpm                                                                                               | 1.7 kB     00:00     
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing     : empty-gridengine                                                                                                                1/1 

Installed:
  empty-gridengine.noarch 0:1.0-1                                                                                                                      

Complete!

Compute Element Installation

OK. This is what all the build-up was for. Use yum to install CE software. I chose the osg-ce-sge since , once again, we use Sun Grid Engine. They have other rpms for PBS, Condor, etc.

Let 'er Rip...

[root@rocksvmfe ~]# yum install osg-ce-sge
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package osg-ce-sge.x86_64 0:3.0.0-24 set to be updated
--> Processing Dependency: osg-ce = 3.0.0-24 for package: osg-ce-sge
--> Processing Dependency: globus-gram-job-manager-sge-setup-seg for package: osg-ce-sge
--> Processing Dependency: osg-configure-sge for package: osg-ce-sge
--> Processing Dependency: gratia-probe-sge for package: osg-ce-sge
--> Running transaction check
---> Package globus-gram-job-manager-sge-setup-seg.x86_64 0:1.0-5.osg set to be updated
--> Processing Dependency: globus-gram-job-manager-sge = 1.0-5.osg for package: globus-gram-job-manager-sge-setup-seg
--> Processing Dependency: globus-gram-job-manager-scripts >= 4 for package: globus-gram-job-manager-sge-setup-seg
--> Processing Dependency: globus-scheduler-event-generator-progs >= 4 for package: globus-gram-job-manager-sge-setup-seg
--> Processing Dependency: libglobus_common.so.0(GLOBUS_COMMON_14)(64bit) for package: globus-gram-job-manager-sge-setup-seg
--> Processing Dependency: libglobus_gsi_credential.so.1()(64bit) for package: globus-gram-job-manager-sge-setup-seg
--> Processing Dependency: libglobus_gsi_cert_utils.so.0()(64bit) for package: globus-gram-job-manager-sge-setup-seg
--> Processing Dependency: libglobus_gssapi_error.so.2()(64bit) for package: globus-gram-job-manager-sge-setup-seg
--> Processing Dependency: libglobus_gsi_sysconfig.so.1()(64bit) for package: globus-gram-job-manager-sge-setup-seg
--> Processing Dependency: libglobus_scheduler_event_generator.so.0()(64bit) for package: globus-gram-job-manager-sge-setup-seg
--> Processing Dependency: libglobus_gram_protocol.so.3()(64bit) for package: globus-gram-job-manager-sge-setup-seg
--> Processing Dependency: libglobus_proxy_ssl.so.1()(64bit) for package: globus-gram-job-manager-sge-setup-seg
--> Processing Dependency: libglobus_gsi_callback.so.0()(64bit) for package: globus-gram-job-manager-sge-setup-seg
--> Processing Dependency: libglobus_gsi_proxy_core.so.0()(64bit) for package: globus-gram-job-manager-sge-setup-seg
--> Processing Dependency: libglobus_xio.so.0()(64bit) for package: globus-gram-job-manager-sge-setup-seg
--> Processing Dependency: libglobus_openssl_error.so.0()(64bit) for package: globus-gram-job-manager-sge-setup-seg
--> Processing Dependency: libglobus_oldgaa.so.0()(64bit) for package: globus-gram-job-manager-sge-setup-seg
--> Processing Dependency: libglobus_gssapi_gsi.so.4()(64bit) for package: globus-gram-job-manager-sge-setup-seg
--> Processing Dependency: libglobus_common.so.0()(64bit) for package: globus-gram-job-manager-sge-setup-seg
--> Processing Dependency: libglobus_gss_assist.so.3()(64bit) for package: globus-gram-job-manager-sge-setup-seg
--> Processing Dependency: libglobus_callout.so.0()(64bit) for package: globus-gram-job-manager-sge-setup-seg
--> Processing Dependency: libglobus_openssl.so.0()(64bit) for package: globus-gram-job-manager-sge-setup-seg
--> Processing Dependency: libglobus_io.so.3()(64bit) for package: globus-gram-job-manager-sge-setup-seg
---> Package gratia-probe-sge.noarch 0:1.09-1 set to be updated
--> Processing Dependency: gratia-probe-common >= 1.09-1 for package: gratia-probe-sge
---> Package osg-ce.x86_64 0:3.0.0-24 set to be updated
--> Processing Dependency: osg-configure-managedfork for package: osg-ce
--> Processing Dependency: edg-mkgridmap for package: osg-ce
--> Processing Dependency: osg-site-web-page for package: osg-ce
--> Processing Dependency: osg-site-verify for package: osg-ce
--> Processing Dependency: gratia-probe-gridftp-transfer for package: osg-ce
--> Processing Dependency: osg-version for package: osg-ce
--> Processing Dependency: osg-configure-gip for package: osg-ce
--> Processing Dependency: osg-configure-misc for package: osg-ce
--> Processing Dependency: osg-configure-ce for package: osg-ce
--> Processing Dependency: globus-gatekeeper for package: osg-ce
--> Processing Dependency: osg-configure for package: osg-ce
--> Processing Dependency: osg-info-services for package: osg-ce
--> Processing Dependency: globus-gram-job-manager-fork for package: osg-ce
--> Processing Dependency: vo-client for package: osg-ce
--> Processing Dependency: osg-configure-cemon for package: osg-ce
--> Processing Dependency: lfc-client for package: osg-ce
--> Processing Dependency: globus-gridftp-server-progs for package: osg-ce
--> Processing Dependency: osg-configure-squid for package: osg-ce
--> Processing Dependency: java-1.6.0-sun-compat for package: osg-ce
--> Processing Dependency: osg-system-profiler for package: osg-ce
--> Processing Dependency: globus-gram-job-manager for package: osg-ce
--> Processing Dependency: osg-configure-gratia for package: osg-ce
--> Processing Dependency: osg-vo-map for package: osg-ce
--> Processing Dependency: osg-client for package: osg-ce
--> Processing Dependency: gip for package: osg-ce
--> Processing Dependency: glite-ce-monitor for package: osg-ce
--> Processing Dependency: gums-client for package: osg-ce
--> Processing Dependency: globus-gram-job-manager-fork-setup-poll for package: osg-ce
--> Processing Dependency: liblcas_lcmaps_gt4_mapping.so.0()(64bit) for package: osg-ce
---> Package osg-configure-sge.noarch 0:0.7.1-1.osg set to be updated
--> Running transaction check
---> Package edg-mkgridmap.noarch 0:4.0.0-4.osg set to be updated
--> Processing Dependency: perl(Net::LDAPS) for package: edg-mkgridmap
--> Processing Dependency: perl-libwww-perl for package: edg-mkgridmap
--> Processing Dependency: vo-client-edgmkgridmap for package: edg-mkgridmap
--> Processing Dependency: perl-Net-SSLeay for package: edg-mkgridmap
--> Processing Dependency: perl(Net::LDAP::Util) for package: edg-mkgridmap
--> Processing Dependency: perl(Net::LDAP) for package: edg-mkgridmap
--> Processing Dependency: perl(Term::ReadKey) for package: edg-mkgridmap
--> Processing Dependency: perl-Crypt-SSLeay for package: edg-mkgridmap
---> Package gip.noarch 0:1.3.3rc1-2.osg set to be updated
---> Package glite-ce-monitor.noarch 0:1.13.1-16.osg set to be updated
Rocks-5.4.3/filelists                                                                                                           | 3.7 MB     00:00     
epel/filelists_db                                                                                                               | 5.4 MB     00:03     
osg/filelists_db                                                                                                                | 340 kB     00:00     
--> Processing Dependency: tomcat5 for package: glite-ce-monitor
--> Processing Dependency: glite-ce-osg-ce-plugin for package: glite-ce-monitor
--> Processing Dependency: /usr/share/java/xml-commons-apis.jar for package: glite-ce-monitor
---> Package globus-callout.x86_64 0:2.1-2.osg set to be updated
---> Package globus-common.x86_64 0:14.3-1.osg set to be updated
---> Package globus-gatekeeper.x86_64 0:8.1-8.osg set to be updated
--> Processing Dependency: globus-common-progs >= 13.4 for package: globus-gatekeeper
---> Package globus-gram-job-manager.x86_64 0:13.5-14.osg set to be updated
--> Processing Dependency: globus-gram-job-manager-callout-error >= 2 for package: globus-gram-job-manager
--> Processing Dependency: globus-gass-copy-progs >= 8 for package: globus-gram-job-manager
--> Processing Dependency: globus-usage >= 3 for package: globus-gram-job-manager
--> Processing Dependency: globus-rsl >= 9 for package: globus-gram-job-manager
--> Processing Dependency: globus-gass-transfer >= 7 for package: globus-gram-job-manager
--> Processing Dependency: globus-gass-cache >= 8 for package: globus-gram-job-manager
--> Processing Dependency: globus-xio-popen-driver >= 2 for package: globus-gram-job-manager
--> Processing Dependency: globus-gass-cache-program >= 2 for package: globus-gram-job-manager
--> Processing Dependency: globus-proxy-utils >= 5 for package: globus-gram-job-manager
--> Processing Dependency: libglobus_gass_cache.so.5()(64bit) for package: globus-gram-job-manager
--> Processing Dependency: libglobus_gass_transfer.so.2()(64bit) for package: globus-gram-job-manager
--> Processing Dependency: libglobus_gram_job_manager_callout_error.so.0()(64bit) for package: globus-gram-job-manager
--> Processing Dependency: libglobus_usage.so.0()(64bit) for package: globus-gram-job-manager
--> Processing Dependency: libglobus_rsl.so.2()(64bit) for package: globus-gram-job-manager
---> Package globus-gram-job-manager-fork.x86_64 0:1.0-7.osg set to be updated
---> Package globus-gram-job-manager-fork-setup-poll.x86_64 0:1.0-7.osg set to be updated
---> Package globus-gram-job-manager-scripts.noarch 0:4.0-7.osg set to be updated
---> Package globus-gram-job-manager-sge.x86_64 0:1.0-5.osg set to be updated
---> Package globus-gram-protocol.x86_64 0:11.1-2.osg set to be updated
---> Package globus-gridftp-server-progs.x86_64 0:6.2-10.osg set to be updated
--> Processing Dependency: globus-gridftp-server = 6.2-10.osg for package: globus-gridftp-server-progs
--> Processing Dependency: globus-xio-gsi-driver >= 2 for package: globus-gridftp-server-progs
--> Processing Dependency: libglobus_ftp_control.so.1()(64bit) for package: globus-gridftp-server-progs
--> Processing Dependency: libglobus_authz.so.0()(64bit) for package: globus-gridftp-server-progs
--> Processing Dependency: libglobus_gridftp_server.so.0()(64bit) for package: globus-gridftp-server-progs
--> Processing Dependency: libglobus_gfork.so.0()(64bit) for package: globus-gridftp-server-progs
--> Processing Dependency: libglobus_gridftp_server_control.so.0()(64bit) for package: globus-gridftp-server-progs
--> Processing Dependency: libglobus_gsi_authz_callout_error.so.0()(64bit) for package: globus-gridftp-server-progs
---> Package globus-gsi-callback.x86_64 0:4.1-2.osg set to be updated
---> Package globus-gsi-cert-utils.x86_64 0:8.1-2.osg set to be updated
---> Package globus-gsi-credential.x86_64 0:5.1-2.osg set to be updated
---> Package globus-gsi-openssl-error.x86_64 0:2.1-2.osg set to be updated
---> Package globus-gsi-proxy-core.x86_64 0:6.1-2.osg set to be updated
---> Package globus-gsi-proxy-ssl.x86_64 0:4.1-2.osg set to be updated
---> Package globus-gsi-sysconfig.x86_64 0:5.1-2.osg set to be updated
---> Package globus-gss-assist.x86_64 0:8.1-2.osg set to be updated
---> Package globus-gssapi-error.x86_64 0:4.1-2.osg set to be updated
---> Package globus-gssapi-gsi.x86_64 0:10.1-2.osg set to be updated
---> Package globus-io.x86_64 0:9.1-2.osg set to be updated
---> Package globus-openssl-module.x86_64 0:3.1-2.osg set to be updated
---> Package globus-scheduler-event-generator.x86_64 0:4.2-2.osg set to be updated
---> Package globus-scheduler-event-generator-progs.x86_64 0:4.2-2.osg set to be updated
---> Package globus-xio.x86_64 0:3.1-3.osg set to be updated
---> Package gratia-probe-common.noarch 0:1.09-1 set to be updated
--> Processing Dependency: pyOpenSSL for package: gratia-probe-common
---> Package gratia-probe-gridftp-transfer.noarch 0:1.09-1 set to be updated
--> Processing Dependency: netlogger for package: gratia-probe-gridftp-transfer
---> Package gums-client.noarch 0:1.3.18.002-3 set to be updated
--> Processing Dependency: gums = 1.3.18.002 for package: gums-client
---> Package java-1.6.0-sun-compat.x86_64 1:1.6.0.29-5.osg.jpp set to be updated
--> Processing Dependency: jdk = 2000:1.6.0_29-fcs for package: java-1.6.0-sun-compat
---> Package lcas-lcmaps-gt4-interface.x86_64 0:0.1.4-7.osg set to be updated
--> Processing Dependency: liblcas.so.0()(64bit) for package: lcas-lcmaps-gt4-interface
--> Processing Dependency: liblcmaps.so.0()(64bit) for package: lcas-lcmaps-gt4-interface
--> Processing Dependency: libglobus_gridmap_callout_error.so.0()(64bit) for package: lcas-lcmaps-gt4-interface
---> Package lfc.x86_64 0:1.8.2-1.el5 set to be updated
--> Processing Dependency: lfc-libs = 1.8.2-1.el5 for package: lfc
--> Processing Dependency: liblfc.so.1()(64bit) for package: lfc
--> Processing Dependency: libgsoap.so.0()(64bit) for package: lfc
--> Processing Dependency: liblcgdm.so.1()(64bit) for package: lfc
---> Package osg-client.noarch 0:3.0.0-14 set to be updated
--> Processing Dependency: lcg-info for package: osg-client
--> Processing Dependency: globus-gram-client-tools for package: osg-client
--> Processing Dependency: gsi-openssh for package: osg-client
--> Processing Dependency: ndt for package: osg-client
--> Processing Dependency: globus-gsi-cert-utils-progs for package: osg-client
--> Processing Dependency: nmap for package: osg-client
--> Processing Dependency: osg-discovery for package: osg-client
--> Processing Dependency: owamp-client for package: osg-client
--> Processing Dependency: bwctl for package: osg-client
--> Processing Dependency: osg-wn-client for package: osg-client
--> Processing Dependency: lcg-infosites for package: osg-client
---> Package osg-configure.noarch 0:0.7.1-1.osg set to be updated
---> Package osg-configure-ce.noarch 0:0.7.1-1.osg set to be updated
---> Package osg-configure-cemon.noarch 0:0.7.1-1.osg set to be updated
---> Package osg-configure-gip.noarch 0:0.7.1-1.osg set to be updated
---> Package osg-configure-gratia.noarch 0:0.7.1-1.osg set to be updated
---> Package osg-configure-managedfork.noarch 0:0.7.1-1.osg set to be updated
---> Package osg-configure-misc.noarch 0:0.7.1-1.osg set to be updated
---> Package osg-configure-squid.noarch 0:0.7.1-1.osg set to be updated
---> Package osg-info-services.noarch 0:0.9-1 set to be updated
---> Package osg-site-verify.noarch 0:3.0.0-1.osg set to be updated
---> Package osg-site-web-page.noarch 0:0.15-3 set to be updated
---> Package osg-system-profiler.noarch 0:0.0.4-1.osg set to be updated
---> Package osg-version.noarch 0:3.0.5-1 set to be updated
---> Package osg-vo-map.noarch 0:0.0.1-1.osg set to be updated
---> Package vo-client.noarch 0:40-2.osg set to be updated
--> Running transaction check
---> Package bwctl.x86_64 0:1.3-5.osg set to be updated
--> Processing Dependency: bwctl-server for package: bwctl
--> Processing Dependency: bwctl-client for package: bwctl
---> Package glite-ce-osg-ce-plugin.noarch 0:1.13.1-3.sl5 set to be updated
---> Package globus-authz.x86_64 0:2.1-2.osg set to be updated
---> Package globus-authz-callout-error.x86_64 0:2.1-2.osg set to be updated
---> Package globus-common-progs.x86_64 0:14.3-1.osg set to be updated
---> Package globus-ftp-control.x86_64 0:4.2-2.osg set to be updated
---> Package globus-gass-cache.x86_64 0:8.1-2.osg set to be updated
---> Package globus-gass-cache-program.x86_64 0:5.0-3.osg set to be updated
--> Processing Dependency: globus-gram-client >= 12 for package: globus-gass-cache-program
--> Processing Dependency: globus-gass-copy >= 8 for package: globus-gass-cache-program
--> Processing Dependency: globus-gass-server-ez >= 4 for package: globus-gass-cache-program
--> Processing Dependency: libglobus_ftp_client.so.2()(64bit) for package: globus-gass-cache-program
--> Processing Dependency: libglobus_gass_copy.so.2()(64bit) for package: globus-gass-cache-program
--> Processing Dependency: libglobus_gram_client.so.3()(64bit) for package: globus-gass-cache-program
--> Processing Dependency: libglobus_gass_server_ez.so.2()(64bit) for package: globus-gass-cache-program
---> Package globus-gass-copy-progs.x86_64 0:8.1-2.osg set to be updated
---> Package globus-gass-transfer.x86_64 0:7.1-2.osg set to be updated
---> Package globus-gfork.x86_64 0:3.1-2.osg set to be updated
---> Package globus-gram-client-tools.x86_64 0:10.0-3.osg set to be updated
---> Package globus-gram-job-manager-callout-error.x86_64 0:2.1-2.osg set to be updated
---> Package globus-gridftp-server.x86_64 0:6.2-10.osg set to be updated
---> Package globus-gridftp-server-control.x86_64 0:2.1-2.osg set to be updated
--> Processing Dependency: globus-xio-pipe-driver >= 2 for package: globus-gridftp-server-control
---> Package globus-gridmap-callout-error.x86_64 0:1.2-1.osg set to be updated
---> Package globus-gsi-cert-utils-progs.x86_64 0:8.1-2.osg set to be updated
---> Package globus-proxy-utils.x86_64 0:5.0-3.osg set to be updated
---> Package globus-rsl.x86_64 0:9.1-2.osg set to be updated
---> Package globus-usage.x86_64 0:3.1-2.osg set to be updated
---> Package globus-xio-gsi-driver.x86_64 0:2.1-2.osg set to be updated
---> Package globus-xio-popen-driver.x86_64 0:2.1-2.osg set to be updated
---> Package gsi-openssh.x86_64 0:5.4-3.osg set to be updated
---> Package gsoap.x86_64 0:2.7.13-4.el5 set to be updated
---> Package gums.noarch 0:1.3.18.002-3 set to be updated
---> Package jdk.x86_64 2000:1.6.0_29-fcs.1.osg set to be updated
---> Package lcas.x86_64 0:1.3.13-9.osg set to be updated
--> Processing Dependency: liblcas_userban.so()(64bit) for package: lcas
---> Package lcg-info.noarch 0:1.12.2-1.osg set to be updated
---> Package lcg-infosites.noarch 0:3.1.0-1.osg set to be updated
---> Package lcgdm-libs.x86_64 0:1.8.2-1.el5 set to be updated
--> Processing Dependency: libvomsapi.so.1()(64bit) for package: lcgdm-libs
---> Package lcmaps.x86_64 0:1.4.28-23.osg set to be updated
--> Processing Dependency: lcmaps-plugins-saz-client for package: lcmaps
--> Processing Dependency: lcmaps-plugins-gums-client for package: lcmaps
--> Processing Dependency: liblcmaps_scas_client.so.0()(64bit) for package: lcmaps
--> Processing Dependency: liblcmaps_verify_proxy.so.0()(64bit) for package: lcmaps
--> Processing Dependency: liblcmaps_posix_enf.so.0()(64bit) for package: lcmaps
---> Package lfc-libs.x86_64 0:1.8.2-1.el5 set to be updated
---> Package ndt.x86_64 0:3.6.4-1.osg set to be updated
---> Package netlogger.noarch 0:4.2.0-1 set to be updated
---> Package nmap.x86_64 2:4.11-1.1 set to be updated
---> Package osg-discovery.noarch 0:1.0.7-3 set to be updated
---> Package osg-wn-client.noarch 0:3.0.0-13 set to be updated
--> Processing Dependency: myproxy for package: osg-wn-client
--> Processing Dependency: fetch-crl for package: osg-wn-client
--> Processing Dependency: glite-fts-client for package: osg-wn-client
--> Processing Dependency: bestman2-client for package: osg-wn-client
--> Processing Dependency: /usr/bin/uberftp for package: osg-wn-client
--> Processing Dependency: dcap-tunnel-gsi for package: osg-wn-client
--> Processing Dependency: lcg-utils for package: osg-wn-client
--> Processing Dependency: /usr/bin/dccp for package: osg-wn-client
--> Processing Dependency: dcache-srmclient for package: osg-wn-client
--> Processing Dependency: lfc-python for package: osg-wn-client
--> Processing Dependency: edg-gridftp-client for package: osg-wn-client
---> Package owamp-client.x86_64 0:3.2rc4-1 set to be updated
---> Package perl-Crypt-SSLeay.x86_64 0:0.51-11.el5 set to be updated
---> Package perl-LDAP.noarch 1:0.33-3.fc6 set to be updated
--> Processing Dependency: perl(Convert::ASN1) for package: perl-LDAP
--> Processing Dependency: perl(IO::Socket::SSL) for package: perl-LDAP
---> Package perl-Net-SSLeay.x86_64 0:1.30-4.fc6 set to be updated
---> Package perl-TermReadKey.x86_64 0:2.30-4.el5 set to be updated
---> Package perl-libwww-perl.noarch 0:5.805-1.1.1 set to be updated
--> Processing Dependency: perl-HTML-Parser >= 3.33 for package: perl-libwww-perl
---> Package pyOpenSSL.x86_64 0:0.6-2.el5 set to be updated
---> Package tomcat5.x86_64 0:5.5.23-0jpp.19.el5_6 set to be updated
--> Processing Dependency: tomcat5-server-lib = 5.5.23-0jpp.19.el5_6 for package: tomcat5
--> Processing Dependency: tomcat5-common-lib = 5.5.23-0jpp.19.el5_6 for package: tomcat5
--> Processing Dependency: tomcat5-server-lib = 5.5.23-0jpp.19.el5_6 for package: tomcat5
--> Processing Dependency: tomcat5-common-lib = 5.5.23-0jpp.19.el5_6 for package: tomcat5
--> Processing Dependency: xerces-j2 >= 2.7.1 for package: tomcat5
--> Processing Dependency: jakarta-commons-daemon >= 1.0.1 for package: tomcat5
--> Processing Dependency: jakarta-commons-launcher >= 0.9 for package: tomcat5
---> Package vo-client-edgmkgridmap.noarch 0:40-2.osg set to be updated
---> Package xml-commons-apis.x86_64 0:1.3.02-0.b2.7jpp.10 set to be updated
--> Processing Dependency: xml-commons = 1.3.02-0.b2.7jpp.10 for package: xml-commons-apis
--> Running transaction check
---> Package bestman2-client.noarch 0:2.1.3-9.osg set to be updated
--> Processing Dependency: bestman2-client-libs = 2.1.3-9.osg for package: bestman2-client
--> Processing Dependency: bestman2-common-libs = 2.1.3-9.osg for package: bestman2-client
---> Package bwctl-client.x86_64 0:1.3-5.osg set to be updated
---> Package bwctl-server.x86_64 0:1.3-5.osg set to be updated
--> Processing Dependency: I2util for package: bwctl-server
---> Package dcache-srmclient.noarch 0:1.9.5.23-4 set to be updated
---> Package dcap.x86_64 0:2.47.5-3.osg set to be updated
--> Processing Dependency: dcap-libs = 2.47.5-3.osg for package: dcap
--> Processing Dependency: libdcap.so.1()(64bit) for package: dcap
---> Package dcap-tunnel-gsi.x86_64 0:2.47.5-3.osg set to be updated
---> Package edg-gridftp-client.x86_64 0:1.2.9.2-3.osg set to be updated
---> Package fetch-crl.noarch 0:2.8.5-1.el5 set to be updated
---> Package glite-fts-client.x86_64 0:3.7.4-4.osg set to be updated
--> Processing Dependency: CGSI-gSOAP for package: glite-fts-client
--> Processing Dependency: libgridsite.so.1.7()(64bit) for package: glite-fts-client
--> Processing Dependency: libglite_data_util.so.0()(64bit) for package: glite-fts-client
--> Processing Dependency: libcgsi_plugin.so.1()(64bit) for package: glite-fts-client
--> Processing Dependency: libglite_data_delegation_api_simple_c.so.2()(64bit) for package: glite-fts-client
--> Processing Dependency: libglite-sd-c.so.2()(64bit) for package: glite-fts-client
---> Package globus-ftp-client.x86_64 0:7.1-2.osg set to be updated
---> Package globus-gass-copy.x86_64 0:8.1-2.osg set to be updated
---> Package globus-gass-server-ez.x86_64 0:4.1-2.osg set to be updated
---> Package globus-gram-client.x86_64 0:12.2-2.osg set to be updated
---> Package globus-xio-pipe-driver.x86_64 0:2.1-2.osg set to be updated
---> Package jakarta-commons-daemon.x86_64 1:1.0.1-6jpp.1 set to be updated
---> Package jakarta-commons-launcher.x86_64 0:0.9-6jpp.1 set to be updated
---> Package lcas-plugins-basic.x86_64 0:1.3.5-6.osg set to be updated
---> Package lcg-utils.x86_64 0:1.11.14-10.osg set to be updated
--> Processing Dependency: gfal for package: lcg-utils
--> Processing Dependency: libgfal.so.1()(64bit) for package: lcg-utils
---> Package lcmaps-plugins-basic.x86_64 0:1.4.5-2.osg set to be updated
---> Package lcmaps-plugins-gums-client.x86_64 0:0.0.2-2.osg set to be updated
--> Processing Dependency: lcmaps-plugins-scas-client for package: lcmaps-plugins-gums-client
---> Package lcmaps-plugins-saz-client.x86_64 0:0.2.22-8.osg set to be updated
--> Processing Dependency: saml2-xacml2-c-lib for package: lcmaps-plugins-saz-client
--> Processing Dependency: libxacml.so.0()(64bit) for package: lcmaps-plugins-saz-client
---> Package lcmaps-plugins-verify-proxy.x86_64 0:1.4.9-3.osg set to be updated
---> Package lfc-python.x86_64 0:1.8.2-1.el5 set to be updated
---> Package myproxy.x86_64 0:5.6-2.osg set to be updated
--> Processing Dependency: myproxy-libs = 5.6-2.osg for package: myproxy
--> Processing Dependency: voms-clients for package: myproxy
--> Processing Dependency: libmyproxy.so.5()(64bit) for package: myproxy
---> Package perl-Convert-ASN1.noarch 0:0.20-1.1 set to be updated
---> Package perl-HTML-Parser.x86_64 0:3.55-1.fc6 set to be updated
--> Processing Dependency: perl-HTML-Tagset >= 3.03 for package: perl-HTML-Parser
---> Package perl-IO-Socket-SSL.noarch 0:1.01-1.fc6 set to be updated
---> Package tomcat5-common-lib.x86_64 0:5.5.23-0jpp.19.el5_6 set to be updated
--> Processing Dependency: tomcat5-servlet-2.4-api = 5.5.23-0jpp.19.el5_6 for package: tomcat5-common-lib
--> Processing Dependency: tomcat5-servlet-2.4-api = 5.5.23-0jpp.19.el5_6 for package: tomcat5-common-lib
--> Processing Dependency: tomcat5-jasper = 5.5.23-0jpp.19.el5_6 for package: tomcat5-common-lib
--> Processing Dependency: tomcat5-jasper = 5.5.23-0jpp.19.el5_6 for package: tomcat5-common-lib
--> Processing Dependency: tomcat5-jsp-2.0-api = 5.5.23-0jpp.19.el5_6 for package: tomcat5-common-lib
--> Processing Dependency: tomcat5-jsp-2.0-api = 5.5.23-0jpp.19.el5_6 for package: tomcat5-common-lib
--> Processing Dependency: jakarta-commons-dbcp >= 1.2.1 for package: tomcat5-common-lib
--> Processing Dependency: jaf >= 1.0.1 for package: tomcat5-common-lib
--> Processing Dependency: javamail >= 1.3.1 for package: tomcat5-common-lib
--> Processing Dependency: jta >= 1.0.1 for package: tomcat5-common-lib
--> Processing Dependency: eclipse-ecj >= 3.1.1 for package: tomcat5-common-lib
--> Processing Dependency: jakarta-commons-logging >= 1.0.4 for package: tomcat5-common-lib
--> Processing Dependency: jakarta-commons-collections >= 3.1 for package: tomcat5-common-lib
--> Processing Dependency: javamail >= 1.3.1 for package: tomcat5-common-lib
--> Processing Dependency: ant >= 1.6 for package: tomcat5-common-lib
--> Processing Dependency: jta >= 1.0.1 for package: tomcat5-common-lib
--> Processing Dependency: mx4j >= 3.0.1 for package: tomcat5-common-lib
--> Processing Dependency: jakarta-commons-el >= 1.0 for package: tomcat5-common-lib
--> Processing Dependency: jakarta-commons-pool >= 1.2 for package: tomcat5-common-lib
--> Processing Dependency: jakarta-commons-logging >= 1.0.4 for package: tomcat5-common-lib
--> Processing Dependency: jakarta-commons-dbcp >= 1.2.1 for package: tomcat5-common-lib
--> Processing Dependency: jakarta-commons-collections >= 3.1 for package: tomcat5-common-lib
--> Processing Dependency: jaf >= 1.0.1 for package: tomcat5-common-lib
--> Processing Dependency: ant >= 1.6 for package: tomcat5-common-lib
--> Processing Dependency: mx4j >= 3.0.1 for package: tomcat5-common-lib
--> Processing Dependency: jakarta-commons-el >= 1.0 for package: tomcat5-common-lib
--> Processing Dependency: eclipse-ecj >= 3.1.1 for package: tomcat5-common-lib
--> Processing Dependency: jakarta-commons-pool >= 1.2 for package: tomcat5-common-lib
---> Package tomcat5-server-lib.x86_64 0:5.5.23-0jpp.19.el5_6 set to be updated
--> Processing Dependency: jakarta-commons-digester >= 1.6 for package: tomcat5-server-lib
--> Processing Dependency: regexp >= 1.3 for package: tomcat5-server-lib
--> Processing Dependency: jakarta-commons-modeler >= 1.1-8jpp.1.0.1 for package: tomcat5-server-lib
--> Processing Dependency: jakarta-commons-fileupload >= 1.0-1jpp for package: tomcat5-server-lib
--> Processing Dependency: regexp >= 1.3 for package: tomcat5-server-lib
--> Processing Dependency: jakarta-commons-beanutils >= 1.7.0 for package: tomcat5-server-lib
--> Processing Dependency: jakarta-commons-digester >= 1.6 for package: tomcat5-server-lib
--> Processing Dependency: jakarta-commons-beanutils >= 1.7.0 for package: tomcat5-server-lib
--> Processing Dependency: jakarta-commons-modeler >= 1.1-8jpp.1.0.1 for package: tomcat5-server-lib
--> Processing Dependency: jakarta-commons-fileupload >= 1.0-1jpp for package: tomcat5-server-lib
---> Package uberftp.x86_64 0:2.6-3.osg set to be updated
---> Package voms.x86_64 0:2.0.6-5.osg set to be updated
---> Package xerces-j2.x86_64 0:2.7.1-7jpp.2.el5_4.2 set to be updated
--> Processing Dependency: xml-commons-resolver >= 1.1 for package: xerces-j2
---> Package xml-commons.x86_64 0:1.3.02-0.b2.7jpp.10 set to be updated
--> Running transaction check
---> Package CGSI-gSOAP.x86_64 0:1.3.4.2-3.osg set to be updated
---> Package I2util.x86_64 0:1.1-1 set to be updated
---> Package ant.x86_64 0:1.6.5-2jpp.2 set to be updated
---> Package bestman2-client-libs.noarch 0:2.1.3-9.osg set to be updated
---> Package bestman2-common-libs.noarch 0:2.1.3-9.osg set to be updated
---> Package classpathx-jaf.x86_64 0:1.0-9jpp.1 set to be updated
---> Package classpathx-mail.x86_64 0:1.1.1-4jpp.2 set to be updated
---> Package dcap-libs.x86_64 0:2.47.5-3.osg set to be updated
---> Package eclipse-ecj.x86_64 1:3.2.1-19.el5.centos set to be updated
---> Package geronimo-specs-compat.x86_64 0:1.0-0.M2.2jpp.12.el5.centos set to be updated
--> Processing Dependency: geronimo-specs = 1.0-0.M2.2jpp.12.el5.centos for package: geronimo-specs-compat
---> Package gfal.x86_64 0:1.11.14-8 set to be updated
---> Package glite-data-delegation-cli.x86_64 0:2.0.1.3-3.osg set to be updated
--> Processing Dependency: libglite_data_delegation_api_c.so.2(libglite_data_delegation_api_c_2)(64bit) for package: glite-data-delegation-cli
--> Processing Dependency: libglite_data_delegation_api_c.so.2()(64bit) for package: glite-data-delegation-cli
---> Package glite-data-util-c.x86_64 0:1.2.3-4.osg set to be updated
---> Package glite-service-discovery-api-c.x86_64 0:2.2.3-2.sl5 set to be updated
---> Package gridsite-libs.x86_64 0:1.7.15-4.osg.3 set to be updated
---> Package jakarta-commons-beanutils.x86_64 0:1.7.0-5jpp.1 set to be updated
---> Package jakarta-commons-collections.x86_64 0:3.2-2jpp.3 set to be updated
---> Package jakarta-commons-dbcp.x86_64 0:1.2.1-7jpp.1 set to be updated
---> Package jakarta-commons-digester.x86_64 0:1.7-5jpp.1 set to be updated
---> Package jakarta-commons-el.x86_64 0:1.0-7jpp.1 set to be updated
---> Package jakarta-commons-fileupload.x86_64 1:1.0-6jpp.1 set to be updated
---> Package jakarta-commons-logging.x86_64 0:1.0.4-6jpp.1 set to be updated
---> Package jakarta-commons-modeler.x86_64 0:1.1-8jpp.3.el5 set to be updated
--> Processing Dependency: jaxp_transform_impl for package: jakarta-commons-modeler
---> Package jakarta-commons-pool.x86_64 0:1.3-5jpp.1 set to be updated
---> Package lcmaps-plugins-scas-client.x86_64 0:0.2.22-8.osg set to be updated
---> Package mx4j.x86_64 1:3.0.1-6jpp.4 set to be updated
--> Processing Dependency: axis >= 1.1 for package: mx4j
--> Processing Dependency: log4j >= 1.2.7 for package: mx4j
--> Processing Dependency: bcel >= 5.0 for package: mx4j
---> Package myproxy-libs.x86_64 0:5.6-2.osg set to be updated
---> Package perl-HTML-Tagset.noarch 0:3.10-2.1.1 set to be updated
---> Package regexp.x86_64 0:1.4-2jpp.2 set to be updated
---> Package saml2-xacml2-c-lib.x86_64 0:1.0.1-7.osg set to be updated
---> Package tomcat5-jasper.x86_64 0:5.5.23-0jpp.19.el5_6 set to be updated
---> Package tomcat5-jsp-2.0-api.x86_64 0:5.5.23-0jpp.19.el5_6 set to be updated
---> Package tomcat5-servlet-2.4-api.x86_64 0:5.5.23-0jpp.19.el5_6 set to be updated
---> Package voms-clients.x86_64 0:2.0.6-5.osg set to be updated
---> Package xml-commons-resolver.x86_64 0:1.1-1jpp.12 set to be updated
--> Running transaction check
---> Package axis.x86_64 0:1.2.1-2jpp.6 set to be updated
--> Processing Dependency: jakarta-commons-discovery for package: axis
--> Processing Dependency: jakarta-commons-httpclient for package: axis
--> Processing Dependency: wsdl4j for package: axis
---> Package bcel.x86_64 0:5.1-8jpp.1 set to be updated
---> Package geronimo-specs.x86_64 0:1.0-0.M2.2jpp.12.el5.centos set to be updated
---> Package glite-data-delegation-api-c.x86_64 0:2.0.0.7-4.osg set to be updated
---> Package log4j.x86_64 0:1.2.13-3jpp.2 set to be updated
---> Package xalan-j2.noarch 0:2.7.0-10.osg set to be updated
--> Running transaction check
---> Package jakarta-commons-discovery.x86_64 1:0.3-4jpp.1 set to be updated
---> Package jakarta-commons-httpclient.x86_64 1:3.0-7jpp.1 set to be updated
---> Package wsdl4j.x86_64 0:1.5.2-4jpp.1 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=======================================================================================================================================================
 Package                                               Arch                 Version                                    Repository                 Size
=======================================================================================================================================================
Installing:
 osg-ce-sge                                            x86_64               3.0.0-24                                   osg                       4.3 k
Installing for dependencies:
 CGSI-gSOAP                                            x86_64               1.3.4.2-3.osg                              osg                        56 k
 I2util                                                x86_64               1.1-1                                      osg                        67 k
 ant                                                   x86_64               1.6.5-2jpp.2                               Rocks-5.4.3               2.3 M
 axis                                                  x86_64               1.2.1-2jpp.6                               Rocks-5.4.3               3.6 M
 bcel                                                  x86_64               5.1-8jpp.1                                 Rocks-5.4.3               1.1 M
 bestman2-client                                       noarch               2.1.3-9.osg                                osg                        25 k
 bestman2-client-libs                                  noarch               2.1.3-9.osg                                osg                       631 k
 bestman2-common-libs                                  noarch               2.1.3-9.osg                                osg                       5.5 M
 bwctl                                                 x86_64               1.3-5.osg                                  osg                       2.0 k
 bwctl-client                                          x86_64               1.3-5.osg                                  osg                        88 k
 bwctl-server                                          x86_64               1.3-5.osg                                  osg                       110 k
 classpathx-jaf                                        x86_64               1.0-9jpp.1                                 Rocks-5.4.3               111 k
 classpathx-mail                                       x86_64               1.1.1-4jpp.2                               Rocks-5.4.3               1.2 M
 dcache-srmclient                                      noarch               1.9.5.23-4                                 osg                       7.2 M
 dcap                                                  x86_64               2.47.5-3.osg                               osg                        26 k
 dcap-libs                                             x86_64               2.47.5-3.osg                               osg                       120 k
 dcap-tunnel-gsi                                       x86_64               2.47.5-3.osg                               osg                        14 k
 eclipse-ecj                                           x86_64               1:3.2.1-19.el5.centos                      Rocks-5.4.3               9.0 M
 edg-gridftp-client                                    x86_64               1.2.9.2-3.osg                              osg                        44 k
 edg-mkgridmap                                         noarch               4.0.0-4.osg                                osg                        21 k
 fetch-crl                                             noarch               2.8.5-1.el5                                epel                       24 k
 geronimo-specs                                        x86_64               1.0-0.M2.2jpp.12.el5.centos                Rocks-5.4.3               259 k
 geronimo-specs-compat                                 x86_64               1.0-0.M2.2jpp.12.el5.centos                Rocks-5.4.3               5.5 k
 gfal                                                  x86_64               1.11.14-8                                  osg                       668 k
 gip                                                   noarch               1.3.3rc1-2.osg                             osg                       361 k
 glite-ce-monitor                                      noarch               1.13.1-16.osg                              osg                        13 M
 glite-ce-osg-ce-plugin                                noarch               1.13.1-3.sl5                               osg                        18 k
 glite-data-delegation-api-c                           x86_64               2.0.0.7-4.osg                              osg                       100 k
 glite-data-delegation-cli                             x86_64               2.0.1.3-3.osg                              osg                        18 k
 glite-data-util-c                                     x86_64               1.2.3-4.osg                                osg                        14 k
 glite-fts-client                                      x86_64               3.7.4-4.osg                                osg                       447 k
 glite-service-discovery-api-c                         x86_64               2.2.3-2.sl5                                osg                        13 k
 globus-authz                                          x86_64               2.1-2.osg                                  osg                        14 k
 globus-authz-callout-error                            x86_64               2.1-2.osg                                  osg                        10 k
 globus-callout                                        x86_64               2.1-2.osg                                  osg                        16 k
 globus-common                                         x86_64               14.3-1.osg                                 osg                       130 k
 globus-common-progs                                   x86_64               14.3-1.osg                                 osg                        30 k
 globus-ftp-client                                     x86_64               7.1-2.osg                                  osg                       107 k
 globus-ftp-control                                    x86_64               4.2-2.osg                                  osg                        73 k
 globus-gass-cache                                     x86_64               8.1-2.osg                                  osg                        26 k
 globus-gass-cache-program                             x86_64               5.0-3.osg                                  osg                        26 k
 globus-gass-copy                                      x86_64               8.1-2.osg                                  osg                        37 k
 globus-gass-copy-progs                                x86_64               8.1-2.osg                                  osg                        38 k
 globus-gass-server-ez                                 x86_64               4.1-2.osg                                  osg                        15 k
 globus-gass-transfer                                  x86_64               7.1-2.osg                                  osg                        43 k
 globus-gatekeeper                                     x86_64               8.1-8.osg                                  osg                        40 k
 globus-gfork                                          x86_64               3.1-2.osg                                  osg                        19 k
 globus-gram-client                                    x86_64               12.2-2.osg                                 osg                        18 k
 globus-gram-client-tools                              x86_64               10.0-3.osg                                 osg                        47 k
 globus-gram-job-manager                               x86_64               13.5-14.osg                                osg                       204 k
 globus-gram-job-manager-callout-error                 x86_64               2.1-2.osg                                  osg                       6.7 k
 globus-gram-job-manager-fork                          x86_64               1.0-7.osg                                  osg                        11 k
 globus-gram-job-manager-fork-setup-poll               x86_64               1.0-7.osg                                  osg                       4.4 k
 globus-gram-job-manager-scripts                       noarch               4.0-7.osg                                  osg                        25 k
 globus-gram-job-manager-sge                           x86_64               1.0-5.osg                                  osg                        14 k
 globus-gram-job-manager-sge-setup-seg                 x86_64               1.0-5.osg                                  osg                        18 k
 globus-gram-protocol                                  x86_64               11.1-2.osg                                 osg                        40 k
 globus-gridftp-server                                 x86_64               6.2-10.osg                                 osg                       164 k
 globus-gridftp-server-control                         x86_64               2.1-2.osg                                  osg                        77 k
 globus-gridftp-server-progs                           x86_64               6.2-10.osg                                 osg                        41 k
 globus-gridmap-callout-error                          x86_64               1.2-1.osg                                  osg                       6.9 k
 globus-gsi-callback                                   x86_64               4.1-2.osg                                  osg                        41 k
 globus-gsi-cert-utils                                 x86_64               8.1-2.osg                                  osg                        19 k
 globus-gsi-cert-utils-progs                           x86_64               8.1-2.osg                                  osg                        26 k
 globus-gsi-credential                                 x86_64               5.1-2.osg                                  osg                        35 k
 globus-gsi-openssl-error                              x86_64               2.1-2.osg                                  osg                        16 k
 globus-gsi-proxy-core                                 x86_64               6.1-2.osg                                  osg                        36 k
 globus-gsi-proxy-ssl                                  x86_64               4.1-2.osg                                  osg                        17 k
 globus-gsi-sysconfig                                  x86_64               5.1-2.osg                                  osg                        29 k
 globus-gss-assist                                     x86_64               8.1-2.osg                                  osg                        34 k
 globus-gssapi-error                                   x86_64               4.1-2.osg                                  osg                        14 k
 globus-gssapi-gsi                                     x86_64               10.1-2.osg                                 osg                        61 k
 globus-io                                             x86_64               9.1-2.osg                                  osg                        44 k
 globus-openssl-module                                 x86_64               3.1-2.osg                                  osg                        15 k
 globus-proxy-utils                                    x86_64               5.0-3.osg                                  osg                        45 k
 globus-rsl                                            x86_64               9.1-2.osg                                  osg                        24 k
 globus-scheduler-event-generator                      x86_64               4.2-2.osg                                  osg                        10 k
 globus-scheduler-event-generator-progs                x86_64               4.2-2.osg                                  osg                        18 k
 globus-usage                                          x86_64               3.1-2.osg                                  osg                        16 k
 globus-xio                                            x86_64               3.1-3.osg                                  osg                       178 k
 globus-xio-gsi-driver                                 x86_64               2.1-2.osg                                  osg                        37 k
 globus-xio-pipe-driver                                x86_64               2.1-2.osg                                  osg                        17 k
 globus-xio-popen-driver                               x86_64               2.1-2.osg                                  osg                        20 k
 gratia-probe-common                                   noarch               1.09-1                                     osg                       132 k
 gratia-probe-gridftp-transfer                         noarch               1.09-1                                     osg                        23 k
 gratia-probe-sge                                      noarch               1.09-1                                     osg                        11 k
 gridsite-libs                                         x86_64               1.7.15-4.osg.3                             osg                        76 k
 gsi-openssh                                           x86_64               5.4-3.osg                                  osg                       276 k
 gsoap                                                 x86_64               2.7.13-4.el5                               epel                      444 k
 gums                                                  noarch               1.3.18.002-3                               osg                        25 M
 gums-client                                           noarch               1.3.18.002-3                               osg                        13 k
 jakarta-commons-beanutils                             x86_64               1.7.0-5jpp.1                               Rocks-5.4.3               567 k
 jakarta-commons-collections                           x86_64               3.2-2jpp.3                                 Rocks-5.4.3               1.2 M
 jakarta-commons-daemon                                x86_64               1:1.0.1-6jpp.1                             Rocks-5.4.3                46 k
 jakarta-commons-dbcp                                  x86_64               1.2.1-7jpp.1                               Rocks-5.4.3               278 k
 jakarta-commons-digester                              x86_64               1.7-5jpp.1                                 Rocks-5.4.3               349 k
 jakarta-commons-discovery                             x86_64               1:0.3-4jpp.1                               Rocks-5.4.3               150 k
 jakarta-commons-el                                    x86_64               1.0-7jpp.1                                 Rocks-5.4.3               268 k
 jakarta-commons-fileupload                            x86_64               1:1.0-6jpp.1                               Rocks-5.4.3                53 k
 jakarta-commons-httpclient                            x86_64               1:3.0-7jpp.1                               Rocks-5.4.3               596 k
 jakarta-commons-launcher                              x86_64               0.9-6jpp.1                                 Rocks-5.4.3                97 k
 jakarta-commons-logging                               x86_64               1.0.4-6jpp.1                               Rocks-5.4.3               115 k
 jakarta-commons-modeler                               x86_64               1.1-8jpp.3.el5                             Rocks-5.4.3               260 k
 jakarta-commons-pool                                  x86_64               1.3-5jpp.1                                 Rocks-5.4.3               142 k
 java-1.6.0-sun-compat                                 x86_64               1:1.6.0.29-5.osg.jpp                       osg                        60 k
 lcas                                                  x86_64               1.3.13-9.osg                               osg                        28 k
 lcas-lcmaps-gt4-interface                             x86_64               0.1.4-7.osg                                osg                        18 k
 lcas-plugins-basic                                    x86_64               1.3.5-6.osg                                osg                        23 k
 lcg-info                                              noarch               1.12.2-1.osg                               osg                        13 k
 lcg-infosites                                         noarch               3.1.0-1.osg                                osg                        10 k
 lcg-utils                                             x86_64               1.11.14-10.osg                             osg                       221 k
 lcgdm-libs                                            x86_64               1.8.2-1.el5                                epel                      100 k
 lcmaps                                                x86_64               1.4.28-23.osg                              osg                        91 k
 lcmaps-plugins-basic                                  x86_64               1.4.5-2.osg                                osg                        38 k
 lcmaps-plugins-gums-client                            x86_64               0.0.2-2.osg                                osg                       2.6 k
 lcmaps-plugins-saz-client                             x86_64               0.2.22-8.osg                               osg                        33 k
 lcmaps-plugins-scas-client                            x86_64               0.2.22-8.osg                               osg                        39 k
 lcmaps-plugins-verify-proxy                           x86_64               1.4.9-3.osg                                osg                        24 k
 lfc                                                   x86_64               1.8.2-1.el5                                epel                       75 k
 lfc-libs                                              x86_64               1.8.2-1.el5                                epel                       44 k
 lfc-python                                            x86_64               1.8.2-1.el5                                epel                      2.2 M
 log4j                                                 x86_64               1.2.13-3jpp.2                              Rocks-5.4.3               728 k
 mx4j                                                  x86_64               1:3.0.1-6jpp.4                             Rocks-5.4.3               2.7 M
 myproxy                                               x86_64               5.6-2.osg                                  osg                        85 k
 myproxy-libs                                          x86_64               5.6-2.osg                                  osg                       120 k
 ndt                                                   x86_64               3.6.4-1.osg                                osg                        37 k
 netlogger                                             noarch               4.2.0-1                                    osg                       624 k
 nmap                                                  x86_64               2:4.11-1.1                                 Rocks-5.4.3               680 k
 osg-ce                                                x86_64               3.0.0-24                                   osg                       5.2 k
 osg-client                                            noarch               3.0.0-14                                   osg                       3.7 k
 osg-configure                                         noarch               0.7.1-1.osg                                osg                       125 k
 osg-configure-ce                                      noarch               0.7.1-1.osg                                osg                       6.9 k
 osg-configure-cemon                                   noarch               0.7.1-1.osg                                osg                       5.6 k
 osg-configure-gip                                     noarch               0.7.1-1.osg                                osg                       8.0 k
 osg-configure-gratia                                  noarch               0.7.1-1.osg                                osg                       5.7 k
 osg-configure-managedfork                             noarch               0.7.1-1.osg                                osg                       5.2 k
 osg-configure-misc                                    noarch               0.7.1-1.osg                                osg                       5.9 k
 osg-configure-sge                                     noarch               0.7.1-1.osg                                osg                       5.4 k
 osg-configure-squid                                   noarch               0.7.1-1.osg                                osg                       5.3 k
 osg-discovery                                         noarch               1.0.7-3                                    osg                        11 M
 osg-info-services                                     noarch               0.9-1                                      osg                        12 k
 osg-site-verify                                       noarch               3.0.0-1.osg                                osg                        25 k
 osg-site-web-page                                     noarch               0.15-3                                     osg                        18 k
 osg-system-profiler                                   noarch               0.0.4-1.osg                                osg                       4.4 k
 osg-version                                           noarch               3.0.5-1                                    osg                       2.4 k
 osg-vo-map                                            noarch               0.0.1-1.osg                                osg                       7.3 k
 osg-wn-client                                         noarch               3.0.0-13                                   osg                       4.8 k
 owamp-client                                          x86_64               3.2rc4-1                                   osg                       208 k
 perl-Convert-ASN1                                     noarch               0.20-1.1                                   Rocks-5.4.3                42 k
 perl-Crypt-SSLeay                                     x86_64               0.51-11.el5                                Rocks-5.4.3                45 k
 perl-HTML-Parser                                      x86_64               3.55-1.fc6                                 Rocks-5.4.3                92 k
 perl-HTML-Tagset                                      noarch               3.10-2.1.1                                 Rocks-5.4.3                15 k
 perl-IO-Socket-SSL                                    noarch               1.01-1.fc6                                 Rocks-5.4.3                49 k
 perl-LDAP                                             noarch               1:0.33-3.fc6                               Rocks-5.4.3               316 k
 perl-Net-SSLeay                                       x86_64               1.30-4.fc6                                 Rocks-5.4.3               192 k
 perl-TermReadKey                                      x86_64               2.30-4.el5                                 epel                       32 k
 perl-libwww-perl                                      noarch               5.805-1.1.1                                Rocks-5.4.3               376 k
 pyOpenSSL                                             x86_64               0.6-2.el5                                  Rocks-5.4.3               120 k
 regexp                                                x86_64               1.4-2jpp.2                                 Rocks-5.4.3               102 k
 saml2-xacml2-c-lib                                    x86_64               1.0.1-7.osg                                osg                       581 k
 tomcat5                                               x86_64               5.5.23-0jpp.19.el5_6                       Rocks-5.4.3               362 k
 tomcat5-common-lib                                    x86_64               5.5.23-0jpp.19.el5_6                       Rocks-5.4.3               225 k
 tomcat5-jasper                                        x86_64               5.5.23-0jpp.19.el5_6                       Rocks-5.4.3               1.1 M
 tomcat5-jsp-2.0-api                                   x86_64               5.5.23-0jpp.19.el5_6                       Rocks-5.4.3               103 k
 tomcat5-server-lib                                    x86_64               5.5.23-0jpp.19.el5_6                       Rocks-5.4.3               4.1 M
 tomcat5-servlet-2.4-api                               x86_64               5.5.23-0jpp.19.el5_6                       Rocks-5.4.3               163 k
 uberftp                                               x86_64               2.6-3.osg                                  osg                        86 k
 vo-client                                             noarch               40-2.osg                                   osg                        16 k
 vo-client-edgmkgridmap                                noarch               40-2.osg                                   osg                       5.0 k
 voms                                                  x86_64               2.0.6-5.osg                                osg                       171 k
 voms-clients                                          x86_64               2.0.6-5.osg                                osg                       180 k
 wsdl4j                                                x86_64               1.5.2-4jpp.1                               Rocks-5.4.3               429 k
 xalan-j2                                              noarch               2.7.0-10.osg                               osg                       1.8 M
 xerces-j2                                             x86_64               2.7.1-7jpp.2.el5_4.2                       Rocks-5.4.3               3.1 M
 xml-commons                                           x86_64               1.3.02-0.b2.7jpp.10                        Rocks-5.4.3                19 k
 xml-commons-apis                                      x86_64               1.3.02-0.b2.7jpp.10                        Rocks-5.4.3               388 k
 xml-commons-resolver                                  x86_64               1.1-1jpp.12                                Rocks-5.4.3               170 k
Updating for dependencies:
 jdk                                                   x86_64               2000:1.6.0_29-fcs.1.osg                    osg                        68 M

Transaction Summary
=======================================================================================================================================================
Install     178 Package(s)
Upgrade       1 Package(s)

Total download size: 179 M
Downloading Packages:
(1/179): bwctl-1.3-5.osg.x86_64.rpm                                                                                             | 2.0 kB     00:00     
(2/179): osg-version-3.0.5-1.noarch.rpm                                                                                         | 2.4 kB     00:00     
(3/179): lcmaps-plugins-gums-client-0.0.2-2.osg.x86_64.rpm                                                                      | 2.6 kB     00:00     
(4/179): osg-client-3.0.0-14.noarch.rpm                                                                                         | 3.7 kB     00:00     
(5/179): osg-ce-sge-3.0.0-24.x86_64.rpm                                                                                         | 4.3 kB     00:00     
(6/179): globus-gram-job-manager-fork-setup-poll-1.0-7.osg.x86_64.rpm                                                           | 4.4 kB     00:00     
(7/179): osg-system-profiler-0.0.4-1.osg.noarch.rpm                                                                             | 4.4 kB     00:00     
(8/179): osg-wn-client-3.0.0-13.noarch.rpm                                                                                      | 4.8 kB     00:00     
(9/179): vo-client-edgmkgridmap-40-2.osg.noarch.rpm                                                                             | 5.0 kB     00:00     
(10/179): osg-ce-3.0.0-24.x86_64.rpm                                                                                            | 5.2 kB     00:00     
(11/179): osg-configure-managedfork-0.7.1-1.osg.noarch.rpm                                                                      | 5.2 kB     00:00     
(12/179): osg-configure-squid-0.7.1-1.osg.noarch.rpm                                                                            | 5.3 kB     00:00     
(13/179): osg-configure-sge-0.7.1-1.osg.noarch.rpm                                                                              | 5.4 kB     00:00     
(14/179): geronimo-specs-compat-1.0-0.M2.2jpp.12.el5.centos.x86_64.rpm                                                          | 5.5 kB     00:00     
(15/179): osg-configure-cemon-0.7.1-1.osg.noarch.rpm                                                                            | 5.6 kB     00:00     
(16/179): osg-configure-gratia-0.7.1-1.osg.noarch.rpm                                                                           | 5.7 kB     00:00     
(17/179): osg-configure-misc-0.7.1-1.osg.noarch.rpm                                                                             | 5.9 kB     00:00     
(18/179): globus-gram-job-manager-callout-error-2.1-2.osg.x86_64.rpm                                                            | 6.7 kB     00:00     
(19/179): globus-gridmap-callout-error-1.2-1.osg.x86_64.rpm                                                                     | 6.9 kB     00:00     
(20/179): osg-configure-ce-0.7.1-1.osg.noarch.rpm                                                                               | 6.9 kB     00:00     
(21/179): osg-vo-map-0.0.1-1.osg.noarch.rpm                                                                                     | 7.3 kB     00:00     
(22/179): osg-configure-gip-0.7.1-1.osg.noarch.rpm                                                                              | 8.0 kB     00:00     
(23/179): globus-authz-callout-error-2.1-2.osg.x86_64.rpm                                                                       |  10 kB     00:00     
(24/179): globus-scheduler-event-generator-4.2-2.osg.x86_64.rpm                                                                 |  10 kB     00:00     
(25/179): lcg-infosites-3.1.0-1.osg.noarch.rpm                                                                                  |  10 kB     00:00     
(26/179): globus-gram-job-manager-fork-1.0-7.osg.x86_64.rpm                                                                     |  11 kB     00:00     
(27/179): gratia-probe-sge-1.09-1.noarch.rpm                                                                                    |  11 kB     00:00     
(28/179): osg-info-services-0.9-1.noarch.rpm                                                                                    |  12 kB     00:00     
(29/179): gums-client-1.3.18.002-3.noarch.rpm                                                                                   |  13 kB     00:00     
(30/179): lcg-info-1.12.2-1.osg.noarch.rpm                                                                                      |  13 kB     00:00     
(31/179): glite-service-discovery-api-c-2.2.3-2.sl5.x86_64.rpm                                                                  |  13 kB     00:00     
(32/179): globus-gssapi-error-4.1-2.osg.x86_64.rpm                                                                              |  14 kB     00:00     
(33/179): dcap-tunnel-gsi-2.47.5-3.osg.x86_64.rpm                                                                               |  14 kB     00:00     
(34/179): globus-gram-job-manager-sge-1.0-5.osg.x86_64.rpm                                                                      |  14 kB     00:00     
(35/179): glite-data-util-c-1.2.3-4.osg.x86_64.rpm                                                                              |  14 kB     00:00     
(36/179): globus-authz-2.1-2.osg.x86_64.rpm                                                                                     |  14 kB     00:00     
(37/179): perl-HTML-Tagset-3.10-2.1.1.noarch.rpm                                                                                |  15 kB     00:00     
(38/179): globus-openssl-module-3.1-2.osg.x86_64.rpm                                                                            |  15 kB     00:00     
(39/179): globus-gass-server-ez-4.1-2.osg.x86_64.rpm                                                                            |  15 kB     00:00     
(40/179): vo-client-40-2.osg.noarch.rpm                                                                                         |  16 kB     00:00     
(41/179): globus-gsi-openssl-error-2.1-2.osg.x86_64.rpm                                                                         |  16 kB     00:00     
(42/179): globus-usage-3.1-2.osg.x86_64.rpm                                                                                     |  16 kB     00:00     
(43/179): globus-callout-2.1-2.osg.x86_64.rpm                                                                                   |  16 kB     00:00     
(44/179): globus-xio-pipe-driver-2.1-2.osg.x86_64.rpm                                                                           |  17 kB     00:00     
(45/179): globus-gsi-proxy-ssl-4.1-2.osg.x86_64.rpm                                                                             |  17 kB     00:00     
(46/179): lcas-lcmaps-gt4-interface-0.1.4-7.osg.x86_64.rpm                                                                      |  18 kB     00:00     
(47/179): globus-gram-job-manager-sge-setup-seg-1.0-5.osg.x86_64.rpm                                                            |  18 kB     00:00     
(48/179): globus-scheduler-event-generator-progs-4.2-2.osg.x86_64.rpm                                                           |  18 kB     00:00     
(49/179): glite-data-delegation-cli-2.0.1.3-3.osg.x86_64.rpm                                                                    |  18 kB     00:00     
(50/179): glite-ce-osg-ce-plugin-1.13.1-3.sl5.noarch.rpm                                                                        |  18 kB     00:00     
(51/179): globus-gram-client-12.2-2.osg.x86_64.rpm                                                                              |  18 kB     00:00     
(52/179): osg-site-web-page-0.15-3.noarch.rpm                                                                                   |  18 kB     00:00     
(53/179): globus-gsi-cert-utils-8.1-2.osg.x86_64.rpm                                                                            |  19 kB     00:00     
(54/179): xml-commons-1.3.02-0.b2.7jpp.10.x86_64.rpm                                                                            |  19 kB     00:00     
(55/179): globus-gfork-3.1-2.osg.x86_64.rpm                                                                                     |  19 kB     00:00     
(56/179): globus-xio-popen-driver-2.1-2.osg.x86_64.rpm                                                                          |  20 kB     00:00     
(57/179): edg-mkgridmap-4.0.0-4.osg.noarch.rpm                                                                                  |  21 kB     00:00     
(58/179): lcas-plugins-basic-1.3.5-6.osg.x86_64.rpm                                                                             |  23 kB     00:00     
(59/179): gratia-probe-gridftp-transfer-1.09-1.noarch.rpm                                                                       |  23 kB     00:00     
(60/179): lcmaps-plugins-verify-proxy-1.4.9-3.osg.x86_64.rpm                                                                    |  24 kB     00:00     
(61/179): fetch-crl-2.8.5-1.el5.noarch.rpm                                                                                      |  24 kB     00:00     
(62/179): globus-rsl-9.1-2.osg.x86_64.rpm                                                                                       |  24 kB     00:00     
(63/179): globus-gram-job-manager-scripts-4.0-7.osg.noarch.rpm                                                                  |  25 kB     00:00     
(64/179): osg-site-verify-3.0.0-1.osg.noarch.rpm                                                                                |  25 kB     00:00    
(65/179): bestman2-client-2.1.3-9.osg.noarch.rpm                                                                                |  25 kB     00:00     
(66/179): globus-gsi-cert-utils-progs-8.1-2.osg.x86_64.rpm                                                                      |  26 kB     00:00     
(67/179): dcap-2.47.5-3.osg.x86_64.rpm                                                                                          |  26 kB     00:00     
(68/179): globus-gass-cache-8.1-2.osg.x86_64.rpm                                                                                |  26 kB     00:00     
(69/179): globus-gass-cache-program-5.0-3.osg.x86_64.rpm                                                                        |  26 kB     00:00     
(70/179): lcas-1.3.13-9.osg.x86_64.rpm                                                                                          |  28 kB     00:00     
(71/179): globus-gsi-sysconfig-5.1-2.osg.x86_64.rpm                                                                             |  29 kB     00:00     
(72/179): globus-common-progs-14.3-1.osg.x86_64.rpm                                                                             |  30 kB     00:00     
(73/179): perl-TermReadKey-2.30-4.el5.x86_64.rpm                                                                                |  32 kB     00:00     
(74/179): lcmaps-plugins-saz-client-0.2.22-8.osg.x86_64.rpm                                                                     |  33 kB     00:00     
(75/179): globus-gss-assist-8.1-2.osg.x86_64.rpm                                                                                |  34 kB     00:00     
(76/179): globus-gsi-credential-5.1-2.osg.x86_64.rpm                                                                            |  35 kB     00:00     
(77/179): globus-gsi-proxy-core-6.1-2.osg.x86_64.rpm                                                                            |  36 kB     00:00     
(78/179): ndt-3.6.4-1.osg.x86_64.rpm                                                                                            |  37 kB     00:00     
(79/179): globus-xio-gsi-driver-2.1-2.osg.x86_64.rpm                                                                            |  37 kB     00:00     
(80/179): globus-gass-copy-8.1-2.osg.x86_64.rpm                                                                                 |  37 kB     00:00     
(81/179): lcmaps-plugins-basic-1.4.5-2.osg.x86_64.rpm                                                                           |  38 kB     00:00     
(82/179): globus-gass-copy-progs-8.1-2.osg.x86_64.rpm                                                                           |  38 kB     00:00     
(83/179): lcmaps-plugins-scas-client-0.2.22-8.osg.x86_64.rpm                                                                    |  39 kB     00:00     
(84/179): globus-gram-protocol-11.1-2.osg.x86_64.rpm                                                                            |  40 kB     00:00     
(85/179): globus-gatekeeper-8.1-8.osg.x86_64.rpm                                                                                |  40 kB     00:00     
(86/179): globus-gsi-callback-4.1-2.osg.x86_64.rpm                                                                              |  41 kB     00:00     
(87/179): globus-gridftp-server-progs-6.2-10.osg.x86_64.rpm                                                                     |  41 kB     00:00     
(88/179): perl-Convert-ASN1-0.20-1.1.noarch.rpm                                                                                 |  42 kB     00:00     
(89/179): globus-gass-transfer-7.1-2.osg.x86_64.rpm                                                                             |  43 kB     00:00     
(90/179): globus-io-9.1-2.osg.x86_64.rpm                                                                                        |  44 kB     00:00     
(91/179): edg-gridftp-client-1.2.9.2-3.osg.x86_64.rpm                                                                           |  44 kB     00:00     
(92/179): lfc-libs-1.8.2-1.el5.x86_64.rpm                                                                                       |  44 kB     00:00     
(93/179): perl-Crypt-SSLeay-0.51-11.el5.x86_64.rpm                                                                              |  45 kB     00:00     
(94/179): globus-proxy-utils-5.0-3.osg.x86_64.rpm                                                                               |  45 kB     00:00     
(95/179): jakarta-commons-daemon-1.0.1-6jpp.1.x86_64.rpm                                                                        |  46 kB     00:00     
(96/179): globus-gram-client-tools-10.0-3.osg.x86_64.rpm                                                                        |  47 kB     00:00     
(97/179): perl-IO-Socket-SSL-1.01-1.fc6.noarch.rpm                                                                              |  49 kB     00:00     
(98/179): jakarta-commons-fileupload-1.0-6jpp.1.x86_64.rpm                                                                      |  53 kB     00:00     
(99/179): CGSI-gSOAP-1.3.4.2-3.osg.x86_64.rpm                                                                                   |  56 kB     00:00     
(100/179): java-1.6.0-sun-compat-1.6.0.29-5.osg.jpp.x86_64.rpm                                                                  |  60 kB     00:00     
(101/179): globus-gssapi-gsi-10.1-2.osg.x86_64.rpm                                                                              |  61 kB     00:00     
(102/179): I2util-1.1-1.x86_64.rpm                                                                                              |  67 kB     00:00     
(103/179): globus-ftp-control-4.2-2.osg.x86_64.rpm                                                                              |  73 kB     00:00     
(104/179): lfc-1.8.2-1.el5.x86_64.rpm                                                                                           |  75 kB     00:00     
(105/179): gridsite-libs-1.7.15-4.osg.3.x86_64.rpm                                                                              |  76 kB     00:00     
(106/179): globus-gridftp-server-control-2.1-2.osg.x86_64.rpm                                                                   |  77 kB     00:00     
(107/179): myproxy-5.6-2.osg.x86_64.rpm                                                                                         |  85 kB     00:00     
(108/179): uberftp-2.6-3.osg.x86_64.rpm                                                                                         |  86 kB     00:00     
(109/179): bwctl-client-1.3-5.osg.x86_64.rpm                                                                                    |  88 kB     00:00     
(110/179): lcmaps-1.4.28-23.osg.x86_64.rpm                                                                                      |  91 kB     00:00     
(111/179): perl-HTML-Parser-3.55-1.fc6.x86_64.rpm                                                                               |  92 kB     00:00     
(112/179): jakarta-commons-launcher-0.9-6jpp.1.x86_64.rpm                                                                       |  97 kB     00:00     
(113/179): glite-data-delegation-api-c-2.0.0.7-4.osg.x86_64.rpm                                                                 | 100 kB     00:00     
(114/179): lcgdm-libs-1.8.2-1.el5.x86_64.rpm                                                                                    | 100 kB     00:00     
(115/179): regexp-1.4-2jpp.2.x86_64.rpm                                                                                         | 102 kB     00:00     
(116/179): tomcat5-jsp-2.0-api-5.5.23-0jpp.19.el5_6.x86_64.rpm                                                                  | 103 kB     00:00     
(117/179): globus-ftp-client-7.1-2.osg.x86_64.rpm                                                                               | 107 kB     00:00     
(118/179): bwctl-server-1.3-5.osg.x86_64.rpm                                                                                    | 110 kB     00:00     
(119/179): classpathx-jaf-1.0-9jpp.1.x86_64.rpm                                                                                 | 111 kB     00:00     
(120/179): jakarta-commons-logging-1.0.4-6jpp.1.x86_64.rpm                                                                      | 115 kB     00:00     
(121/179): dcap-libs-2.47.5-3.osg.x86_64.rpm                                                                                    | 120 kB     00:00     
(122/179): pyOpenSSL-0.6-2.el5.x86_64.rpm                                                                                       | 120 kB     00:00     
(123/179): myproxy-libs-5.6-2.osg.x86_64.rpm                                                                                    | 120 kB     00:00     
(124/179): osg-configure-0.7.1-1.osg.noarch.rpm                                                                                 | 125 kB     00:00     
(125/179): globus-common-14.3-1.osg.x86_64.rpm                                                                                  | 130 kB     00:00     
(126/179): gratia-probe-common-1.09-1.noarch.rpm                                                                                | 132 kB     00:00     
(127/179): jakarta-commons-pool-1.3-5jpp.1.x86_64.rpm                                                                           | 142 kB     00:00     
(128/179): jakarta-commons-discovery-0.3-4jpp.1.x86_64.rpm                                                                      | 150 kB     00:00     
(129/179): tomcat5-servlet-2.4-api-5.5.23-0jpp.19.el5_6.x86_64.rpm                                                              | 163 kB     00:00     
(130/179): globus-gridftp-server-6.2-10.osg.x86_64.rpm                                                                          | 164 kB     00:00     
(131/179): xml-commons-resolver-1.1-1jpp.12.x86_64.rpm                                                                          | 170 kB     00:00     
(132/179): voms-2.0.6-5.osg.x86_64.rpm                                                                                          | 171 kB     00:00     
(133/179): globus-xio-3.1-3.osg.x86_64.rpm                                                                                      | 178 kB     00:00     
(134/179): voms-clients-2.0.6-5.osg.x86_64.rpm                                                                                  | 180 kB     00:00     
(135/179): perl-Net-SSLeay-1.30-4.fc6.x86_64.rpm                                                                                | 192 kB     00:00     
(136/179): globus-gram-job-manager-13.5-14.osg.x86_64.rpm                                                                       | 204 kB     00:00     
(137/179): owamp-client-3.2rc4-1.x86_64.rpm                                                                                     | 208 kB     00:00     
(138/179): lcg-utils-1.11.14-10.osg.x86_64.rpm                                                                                  | 221 kB     00:00     
(139/179): tomcat5-common-lib-5.5.23-0jpp.19.el5_6.x86_64.rpm                                                                   | 225 kB     00:00     
(140/179): geronimo-specs-1.0-0.M2.2jpp.12.el5.centos.x86_64.rpm                                                                | 259 kB     00:00     
(141/179): jakarta-commons-modeler-1.1-8jpp.3.el5.x86_64.rpm                                                                    | 260 kB     00:00     
(142/179): jakarta-commons-el-1.0-7jpp.1.x86_64.rpm                                                                             | 268 kB     00:00     
(143/179): gsi-openssh-5.4-3.osg.x86_64.rpm                                                                                     | 276 kB     00:01     
(144/179): jakarta-commons-dbcp-1.2.1-7jpp.1.x86_64.rpm                                                                         | 278 kB     00:00     
(145/179): perl-LDAP-0.33-3.fc6.noarch.rpm                                                                                      | 316 kB     00:00     
(146/179): jakarta-commons-digester-1.7-5jpp.1.x86_64.rpm                                                                       | 349 kB     00:00     
(147/179): gip-1.3.3rc1-2.osg.noarch.rpm                                                                                        | 361 kB     00:00     
(148/179): tomcat5-5.5.23-0jpp.19.el5_6.x86_64.rpm                                                                              | 362 kB     00:00     
(149/179): perl-libwww-perl-5.805-1.1.1.noarch.rpm                                                                              | 376 kB     00:00     
(150/179): xml-commons-apis-1.3.02-0.b2.7jpp.10.x86_64.rpm                                                                      | 388 kB     00:00     
(151/179): wsdl4j-1.5.2-4jpp.1.x86_64.rpm                                                                                       | 429 kB     00:00     
(152/179): gsoap-2.7.13-4.el5.x86_64.rpm                                                                                        | 444 kB     00:00     
(153/179): glite-fts-client-3.7.4-4.osg.x86_64.rpm                                                                              | 447 kB     00:00     
(154/179): jakarta-commons-beanutils-1.7.0-5jpp.1.x86_64.rpm                                                                    | 567 kB     00:00     
(155/179): saml2-xacml2-c-lib-1.0.1-7.osg.x86_64.rpm                                                                            | 581 kB     00:00     
(156/179): jakarta-commons-httpclient-3.0-7jpp.1.x86_64.rpm                                                                     | 596 kB     00:00     
(157/179): netlogger-4.2.0-1.noarch.rpm                                                                                         | 624 kB     00:00     
(158/179): bestman2-client-libs-2.1.3-9.osg.noarch.rpm                                                                          | 631 kB     00:00     
(159/179): gfal-1.11.14-8.x86_64.rpm                                                                                            | 668 kB     00:00     
(160/179): nmap-4.11-1.1.x86_64.rpm                                                                                             | 680 kB     00:00     
(161/179): log4j-1.2.13-3jpp.2.x86_64.rpm                                                                                       | 728 kB     00:00     
(162/179): tomcat5-jasper-5.5.23-0jpp.19.el5_6.x86_64.rpm                                                                       | 1.1 MB     00:00     
(163/179): bcel-5.1-8jpp.1.x86_64.rpm                                                                                           | 1.1 MB     00:00     
(164/179): jakarta-commons-collections-3.2-2jpp.3.x86_64.rpm                                                                    | 1.2 MB     00:00     
(165/179): classpathx-mail-1.1.1-4jpp.2.x86_64.rpm                                                                              | 1.2 MB     00:00     
(166/179): xalan-j2-2.7.0-10.osg.noarch.rpm                                                                                     | 1.8 MB     00:01     
(167/179): lfc-python-1.8.2-1.el5.x86_64.rpm                                                                                    | 2.2 MB     00:02     
(168/179): ant-1.6.5-2jpp.2.x86_64.rpm                                                                                          | 2.3 MB     00:00     
(169/179): mx4j-3.0.1-6jpp.4.x86_64.rpm                                                                                         | 2.7 MB     00:00     
(170/179): xerces-j2-2.7.1-7jpp.2.el5_4.2.x86_64.rpm                                                                            | 3.1 MB     00:00     
(171/179): axis-1.2.1-2jpp.6.x86_64.rpm                                                                                         | 3.6 MB     00:00     
(172/179): tomcat5-server-lib-5.5.23-0jpp.19.el5_6.x86_64.rpm                                                                   | 4.1 MB     00:00     
(173/179): bestman2-common-libs-2.1.3-9.osg.noarch.rpm                                                                          | 5.5 MB     00:05     
(174/179): dcache-srmclient-1.9.5.23-4.noarch.rpm                                                                               | 7.2 MB     00:05     
(175/179): eclipse-ecj-3.2.1-19.el5.centos.x86_64.rpm                                                                           | 9.0 MB     00:00     
(176/179): osg-discovery-1.0.7-3.noarch.rpm                                                                                     |  11 MB     00:06     
(177/179): glite-ce-monitor-1.13.1-16.osg.noarch.rpm                                                                            |  13 MB     00:08     
(178/179): gums-1.3.18.002-3.noarch.rpm                                                                                         |  25 MB     00:16     
(179/179): jdk-1.6.0_29-fcs.1.osg.x86_64.rpm                                                                                    |  68 MB     00:41     
-------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                  1.5 MB/s | 179 MB     02:03     
warning: rpmts_HdrFromFdno: Header V3 DSA signature: NOKEY, key ID 217521f6
epel/gpgkey                                                                                                                     | 1.7 kB     00:00     
Importing GPG key 0x217521F6 "Fedora EPEL <epel@fedoraproject.org>" from /etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing     : globus-common                                                                                                                 1/181 
  Installing     : globus-gsi-openssl-error                                                                                                      2/181 
  Installing     : globus-gsi-proxy-ssl                                                                                                          3/181 
  Installing     : globus-openssl-module                                                                                                         4/181 
  Installing     : globus-gsi-cert-utils                                                                                                         5/181 
  Installing     : globus-gsi-sysconfig                                                                                                          6/181 
  Installing     : globus-gsi-callback                                                                                                           7/181 
  Installing     : globus-gsi-credential                                                                                                         8/181 
  Installing     : globus-gsi-proxy-core                                                                                                         9/181 
  Installing     : globus-gssapi-gsi                                                                                                            10/181 
  Installing     : globus-callout                                                                                                               11/181 
  Installing     : globus-gss-assist                                                                                                            12/181 
  Installing     : globus-xio                                                                                                                   13/181 
  Installing     : globus-gssapi-error                                                                                                          14/181 
  Installing     : jakarta-commons-logging                                                                                                      15/181 
  Installing     : voms                                                                                                                         16/181 
  Installing     : globus-xio-gsi-driver                                                                                                        17/181 
  Installing     : globus-io                                                                                                                    18/181 
  Installing     : globus-gram-protocol                                                                                                         19/181 
  Installing     : globus-gass-transfer                                                                                                         20/181 
  Installing     : globus-ftp-control                                                                                                           21/181 
  Installing     : globus-usage                                                                                                                 22/181 
  Installing     : globus-common-progs                                                                                                          23/181 
  Installing     : tomcat5-servlet-2.4-api                                                                                                      24/181 
  Installing     : globus-gram-job-manager-scripts                                                                                              25/181 
  Installing     : vo-client                                                                                                                    26/181 
  Installing     : CGSI-gSOAP                                                                                                                   27/181 
  Installing     : globus-rsl                                                                                                                   28/181 
  Installing     : jakarta-commons-collections                                                                                                  29/181 
  Installing     : classpathx-jaf                                                                                                               30/181 
  Installing     : jakarta-commons-beanutils                                                                                                    31/181 
  Installing     : globus-scheduler-event-generator                                                                                             32/181 
  Installing     : lcgdm-libs                                                                                                                   33/181 
  Installing     : globus-authz-callout-error                                                                                                   34/181 
  Installing     : gridsite-libs                                                                                                                35/181 
  Installing     : osg-version                                                                                                                  36/181 
  Installing     : osg-vo-map                                                                                                                   37/181 
  Installing     : osg-system-profiler                                                                                                          38/181 
  Installing     : globus-authz                                                                                                                 39/181 
  Installing     : lfc-libs                                                                                                                     40/181 
  Installing     : jakarta-commons-digester                                                                                                     41/181 
  Installing     : globus-gram-client                                                                                                           42/181 
  Installing     : tomcat5-jasper                                                                                                               43/181 
  Installing     : globus-gass-server-ez                                                                                                        44/181 
  Installing     : globus-gfork                                                                                                                 45/181 
  Installing     : globus-xio-popen-driver                                                                                                      46/181 
  Installing     : globus-ftp-client                                                                                                            47/181 
  Installing     : globus-gass-copy                                                                                                             48/181 
  Installing     : globus-gass-copy-progs                                                                                                       49/181 
  Installing     : globus-proxy-utils                                                                                                           50/181 
  Installing     : globus-gass-cache                                                                                                            51/181 
  Installing     : globus-gass-cache-program                                                                                                    52/181 
  Installing     : dcap-libs                                                                                                                    53/181 
  Installing     : regexp                                                                                                                       54/181 
  Installing     : gsoap                                                                                                                        55/181 
  Installing     : lfc                                                                                                                          56/181 
  Installing     : jakarta-commons-el                                                                                                           57/181 
  Installing     : jakarta-commons-pool                                                                                                         58/181 
  Installing     : saml2-xacml2-c-lib                                                                                                           59/181 
  Installing     : perl-Net-SSLeay                                                                                                              60/181 
  Installing     : glite-service-discovery-api-c                                                                                                61/181 
  Installing     : glite-data-util-c                                                                                                            62/181 
  Installing     : xml-commons                                                                                                                  63/181 
  Installing     : xml-commons-apis                                                                                                             64/181 
  Installing     : osg-configure                                                                                                                65/181 
  Installing     : gip                                                                                                                          66/181 
  Installing     : jakarta-commons-dbcp                                                                                                         67/181 
  Installing     : gfal                                                                                                                         68/181 
  Installing     : lcg-utils                                                                                                                    69/181 
  Installing     : bcel                                                                                                                         70/181 
  Installing     : dcap                                                                                                                         71/181 
  Installing     : dcap-tunnel-gsi                                                                                                              72/181 
  Installing     : edg-gridftp-client                                                                                                           73/181 
  Installing     : globus-gram-client-tools                                                                                                     74/181 
  Installing     : lfc-python                                                                                                                   75/181 
  Installing     : globus-scheduler-event-generator-progs                                                                                       76/181 
  Installing     : glite-data-delegation-api-c                                                                                                  77/181 
  Installing     : glite-data-delegation-cli                                                                                                    78/181 
  Installing     : glite-fts-client                                                                                                             79/181 
  Installing     : jakarta-commons-fileupload                                                                                                   80/181 
  Installing     : tomcat5-jsp-2.0-api                                                                                                          81/181 
  Installing     : globus-gatekeeper                                                                                                            82/181 
  Installing     : gsi-openssh                                                                                                                  83/181 
  Installing     : myproxy-libs                                                                                                                 84/181 
  Installing     : voms-clients                                                                                                                 85/181 
  Installing     : myproxy                                                                                                                      86/181 
  Installing     : jakarta-commons-httpclient                                                                                                   87/181 
  Installing     : jakarta-commons-discovery                                                                                                    88/181 
  Installing     : globus-gridmap-callout-error                                                                                                 89/181 
  Installing     : globus-xio-pipe-driver                                                                                                       90/181 
  Installing     : globus-gridftp-server-control                                                                                                91/181 
  Installing     : globus-gridftp-server                                                                                                        92/181 
  Installing     : globus-gridftp-server-progs                                                                                                  93/181 
  Installing     : uberftp                                                                                                                      94/181 
  Installing     : globus-gram-job-manager-callout-error                                                                                        95/181 
  Installing     : globus-gram-job-manager                                                                                                      96/181 
  Installing     : lcmaps-plugins-basic                                                                                                         97/181 
  Installing     : jakarta-commons-daemon                                                                                                       98/181 
  Installing     : perl-Crypt-SSLeay                                                                                                            99/181 
  Installing     : eclipse-ecj                                                                                                                 100/181 
  Installing     : nmap                                                                                                                        101/181 
  Installing     : ndt                                                                                                                         102/181 
  Installing     : owamp-client                                                                                                                103/181 
  Installing     : pyOpenSSL                                                                                                                   104/181 
  Installing     : I2util                                                                                                                      105/181 
  Installing     : bwctl-server                                                                                                                106/181 
  Installing     : jakarta-commons-launcher                                                                                                    107/181 
  Installing     : perl-TermReadKey                                                                                                            108/181 
  Installing     : bwctl-client                                                                                                                109/181 
  Installing     : lcmaps-plugins-verify-proxy                                                                                                 110/181 
  Installing     : gratia-probe-common                                                                                                         111/181 
  Installing     : gratia-probe-sge                                                                                                            112/181 
  Installing     : bwctl                                                                                                                       113/181 
  Installing     : osg-info-services                                                                                                           114/181 
  Installing     : osg-site-web-page                                                                                                           115/181 
  Installing     : perl-IO-Socket-SSL                                                                                                          116/181 
  Installing     : globus-gram-job-manager-sge                                                                                                 117/181 
  Installing     : globus-gram-job-manager-sge-setup-seg                                                                                       118/181 
globus-scheduler-event-generator (sge) is not running
  Installing     : vo-client-edgmkgridmap                                                                                                      119/181 
  Installing     : globus-gsi-cert-utils-progs                                                                                                 120/181 
  Installing     : osg-configure-gip                                                                                                           121/181 
  Updating       : jdk                                                                                                                         122/181 
Unpacking JAR files...
	rt.jar...
	jsse.jar...
	charsets.jar...
	tools.jar...
	localedata.jar...
	plugin.jar...
	javaws.jar...
	deploy.jar...
  Installing     : java-1.6.0-sun-compat                                                                                                       123/181 
  Installing     : classpathx-mail                                                                                                             124/181 
  Installing     : bestman2-client-libs                                                                                                        125/181 
  Installing     : osg-discovery                                                                                                               126/181 
  Installing     : dcache-srmclient                                                                                                            127/181 
  Installing     : gums                                                                                                                        128/181 
  Installing     : gums-client                                                                                                                 129/181 
  Installing     : bestman2-common-libs                                                                                                        130/181 
  Installing     : bestman2-client                                                                                                             131/181 
  Installing     : perl-HTML-Tagset                                                                                                            132/181 
  Installing     : perl-HTML-Parser                                                                                                            133/181 
  Installing     : perl-libwww-perl                                                                                                            134/181 
  Installing     : osg-site-verify                                                                                                             135/181 
  Installing     : osg-configure-ce                                                                                                            136/181 
  Installing     : osg-configure-cemon                                                                                                         137/181 
  Installing     : osg-configure-sge                                                                                                           138/181 
  Installing     : perl-Convert-ASN1                                                                                                           139/181 
  Installing     : perl-LDAP                                                                                                                   140/181 
  Installing     : lcg-infosites                                                                                                               141/181 
  Installing     : lcg-info                                                                                                                    142/181 
  Installing     : edg-mkgridmap                                                                                                               143/181 
  Installing     : osg-configure-squid                                                                                                         144/181 
  Installing     : osg-configure-gratia                                                                                                        145/181 
  Installing     : fetch-crl                                                                                                                   146/181 
  Installing     : osg-wn-client                                                                                                               147/181 
  Installing     : osg-client                                                                                                                  148/181 
  Installing     : osg-configure-misc                                                                                                          149/181 
  Installing     : osg-configure-managedfork                                                                                                   150/181 
  Installing     : netlogger                                                                                                                   151/181 
  Installing     : gratia-probe-gridftp-transfer                                                                                               152/181 
  Installing     : xerces-j2                                                                                                                   153/181 
  Installing     : log4j                                                                                                                       154/181 
  Installing     : xml-commons-resolver                                                                                                        155/181 
  Installing     : lcmaps-plugins-scas-client                                                                                                  156/181 
  Installing     : lcas                                                                                                                        157/181 
  Installing     : lcmaps-plugins-saz-client                                                                                                   158/181 
  Installing     : globus-gram-job-manager-fork                                                                                                159/181 
  Installing     : globus-gram-job-manager-fork-setup-poll                                                                                     160/181 
  Installing     : wsdl4j                                                                                                                      161/181 
  Installing     : axis                                                                                                                        162/181 
  Installing     : mx4j                                                                                                                        163/181 
  Installing     : geronimo-specs                                                                                                              164/181 
  Installing     : ant                                                                                                                         165/181 
  Installing     : lcas-plugins-basic                                                                                                          166/181 
  Installing     : geronimo-specs-compat                                                                                                       167/181 
  Installing     : tomcat5-common-lib                                                                                                          168/181 
  Installing     : lcmaps-plugins-gums-client                                                                                                  169/181 
  Installing     : lcmaps                                                                                                                      170/181 
  Installing     : lcas-lcmaps-gt4-interface                                                                                                   171/181 
  Installing     : xalan-j2                                                                                                                    172/181 
  Installing     : jakarta-commons-modeler                                                                                                     173/181 
  Installing     : tomcat5-server-lib                                                                                                          174/181 
  Installing     : tomcat5                                                                                                                     175/181 
  Installing     : glite-ce-monitor                                                                                                            176/181 
  Installing     : osg-ce                                                                                                                      177/181 
  Installing     : osg-ce-sge                                                                                                                  178/181 
  Installing     : glite-ce-osg-ce-plugin                                                                                                      179/181 
  Cleanup        : jdk                                                                                                                         180/181 
  Cleanup        : jdk                                                                                                                         181/181 

Installed:
  osg-ce-sge.x86_64 0:3.0.0-24                                                                                                                         

Dependency Installed:
  CGSI-gSOAP.x86_64 0:1.3.4.2-3.osg                                          I2util.x86_64 0:1.1-1                                                    
  ant.x86_64 0:1.6.5-2jpp.2                                                  axis.x86_64 0:1.2.1-2jpp.6                                               
  bcel.x86_64 0:5.1-8jpp.1                                                   bestman2-client.noarch 0:2.1.3-9.osg                                     
  bestman2-client-libs.noarch 0:2.1.3-9.osg                                  bestman2-common-libs.noarch 0:2.1.3-9.osg                                
  bwctl.x86_64 0:1.3-5.osg                                                   bwctl-client.x86_64 0:1.3-5.osg                                          
  bwctl-server.x86_64 0:1.3-5.osg                                            classpathx-jaf.x86_64 0:1.0-9jpp.1                                       
  classpathx-mail.x86_64 0:1.1.1-4jpp.2                                      dcache-srmclient.noarch 0:1.9.5.23-4                                     
  dcap.x86_64 0:2.47.5-3.osg                                                 dcap-libs.x86_64 0:2.47.5-3.osg                                          
  dcap-tunnel-gsi.x86_64 0:2.47.5-3.osg                                      eclipse-ecj.x86_64 1:3.2.1-19.el5.centos                                 
  edg-gridftp-client.x86_64 0:1.2.9.2-3.osg                                  edg-mkgridmap.noarch 0:4.0.0-4.osg                                       
  fetch-crl.noarch 0:2.8.5-1.el5                                             geronimo-specs.x86_64 0:1.0-0.M2.2jpp.12.el5.centos                      
  geronimo-specs-compat.x86_64 0:1.0-0.M2.2jpp.12.el5.centos                 gfal.x86_64 0:1.11.14-8                                                  
  gip.noarch 0:1.3.3rc1-2.osg                                                glite-ce-monitor.noarch 0:1.13.1-16.osg                                  
  glite-ce-osg-ce-plugin.noarch 0:1.13.1-3.sl5                               glite-data-delegation-api-c.x86_64 0:2.0.0.7-4.osg                       
  glite-data-delegation-cli.x86_64 0:2.0.1.3-3.osg                           glite-data-util-c.x86_64 0:1.2.3-4.osg                                   
  glite-fts-client.x86_64 0:3.7.4-4.osg                                      glite-service-discovery-api-c.x86_64 0:2.2.3-2.sl5                       
  globus-authz.x86_64 0:2.1-2.osg                                            globus-authz-callout-error.x86_64 0:2.1-2.osg                            
  globus-callout.x86_64 0:2.1-2.osg                                          globus-common.x86_64 0:14.3-1.osg                                        
  globus-common-progs.x86_64 0:14.3-1.osg                                    globus-ftp-client.x86_64 0:7.1-2.osg                                     
  globus-ftp-control.x86_64 0:4.2-2.osg                                      globus-gass-cache.x86_64 0:8.1-2.osg                                     
  globus-gass-cache-program.x86_64 0:5.0-3.osg                               globus-gass-copy.x86_64 0:8.1-2.osg                                      
  globus-gass-copy-progs.x86_64 0:8.1-2.osg                                  globus-gass-server-ez.x86_64 0:4.1-2.osg                                 
  globus-gass-transfer.x86_64 0:7.1-2.osg                                    globus-gatekeeper.x86_64 0:8.1-8.osg                                     
  globus-gfork.x86_64 0:3.1-2.osg                                            globus-gram-client.x86_64 0:12.2-2.osg                                   
  globus-gram-client-tools.x86_64 0:10.0-3.osg                               globus-gram-job-manager.x86_64 0:13.5-14.osg                             
  globus-gram-job-manager-callout-error.x86_64 0:2.1-2.osg                   globus-gram-job-manager-fork.x86_64 0:1.0-7.osg                          
  globus-gram-job-manager-fork-setup-poll.x86_64 0:1.0-7.osg                 globus-gram-job-manager-scripts.noarch 0:4.0-7.osg                       
  globus-gram-job-manager-sge.x86_64 0:1.0-5.osg                             globus-gram-job-manager-sge-setup-seg.x86_64 0:1.0-5.osg                 
  globus-gram-protocol.x86_64 0:11.1-2.osg                                   globus-gridftp-server.x86_64 0:6.2-10.osg                                
  globus-gridftp-server-control.x86_64 0:2.1-2.osg                           globus-gridftp-server-progs.x86_64 0:6.2-10.osg                          
  globus-gridmap-callout-error.x86_64 0:1.2-1.osg                            globus-gsi-callback.x86_64 0:4.1-2.osg                                   
  globus-gsi-cert-utils.x86_64 0:8.1-2.osg                                   globus-gsi-cert-utils-progs.x86_64 0:8.1-2.osg                           
  globus-gsi-credential.x86_64 0:5.1-2.osg                                   globus-gsi-openssl-error.x86_64 0:2.1-2.osg                              
  globus-gsi-proxy-core.x86_64 0:6.1-2.osg                                   globus-gsi-proxy-ssl.x86_64 0:4.1-2.osg                                  
  globus-gsi-sysconfig.x86_64 0:5.1-2.osg                                    globus-gss-assist.x86_64 0:8.1-2.osg                                     
  globus-gssapi-error.x86_64 0:4.1-2.osg                                     globus-gssapi-gsi.x86_64 0:10.1-2.osg                                    
  globus-io.x86_64 0:9.1-2.osg                                               globus-openssl-module.x86_64 0:3.1-2.osg                                 
  globus-proxy-utils.x86_64 0:5.0-3.osg                                      globus-rsl.x86_64 0:9.1-2.osg                                            
  globus-scheduler-event-generator.x86_64 0:4.2-2.osg                        globus-scheduler-event-generator-progs.x86_64 0:4.2-2.osg                
  globus-usage.x86_64 0:3.1-2.osg                                            globus-xio.x86_64 0:3.1-3.osg                                            
  globus-xio-gsi-driver.x86_64 0:2.1-2.osg                                   globus-xio-pipe-driver.x86_64 0:2.1-2.osg                                
  globus-xio-popen-driver.x86_64 0:2.1-2.osg                                 gratia-probe-common.noarch 0:1.09-1                                      
  gratia-probe-gridftp-transfer.noarch 0:1.09-1                              gratia-probe-sge.noarch 0:1.09-1                                         
  gridsite-libs.x86_64 0:1.7.15-4.osg.3                                      gsi-openssh.x86_64 0:5.4-3.osg                                           
  gsoap.x86_64 0:2.7.13-4.el5                                                gums.noarch 0:1.3.18.002-3                                               
  gums-client.noarch 0:1.3.18.002-3                                          jakarta-commons-beanutils.x86_64 0:1.7.0-5jpp.1                          
  jakarta-commons-collections.x86_64 0:3.2-2jpp.3                            jakarta-commons-daemon.x86_64 1:1.0.1-6jpp.1                             
  jakarta-commons-dbcp.x86_64 0:1.2.1-7jpp.1                                 jakarta-commons-digester.x86_64 0:1.7-5jpp.1                             
  jakarta-commons-discovery.x86_64 1:0.3-4jpp.1                              jakarta-commons-el.x86_64 0:1.0-7jpp.1                                   
  jakarta-commons-fileupload.x86_64 1:1.0-6jpp.1                             jakarta-commons-httpclient.x86_64 1:3.0-7jpp.1                           
  jakarta-commons-launcher.x86_64 0:0.9-6jpp.1                               jakarta-commons-logging.x86_64 0:1.0.4-6jpp.1                            
  jakarta-commons-modeler.x86_64 0:1.1-8jpp.3.el5                            jakarta-commons-pool.x86_64 0:1.3-5jpp.1                                 
  java-1.6.0-sun-compat.x86_64 1:1.6.0.29-5.osg.jpp                          lcas.x86_64 0:1.3.13-9.osg                                               
  lcas-lcmaps-gt4-interface.x86_64 0:0.1.4-7.osg                             lcas-plugins-basic.x86_64 0:1.3.5-6.osg                                  
  lcg-info.noarch 0:1.12.2-1.osg                                             lcg-infosites.noarch 0:3.1.0-1.osg                                       
  lcg-utils.x86_64 0:1.11.14-10.osg                                          lcgdm-libs.x86_64 0:1.8.2-1.el5                                          
  lcmaps.x86_64 0:1.4.28-23.osg                                              lcmaps-plugins-basic.x86_64 0:1.4.5-2.osg                                
  lcmaps-plugins-gums-client.x86_64 0:0.0.2-2.osg                            lcmaps-plugins-saz-client.x86_64 0:0.2.22-8.osg                          
  lcmaps-plugins-scas-client.x86_64 0:0.2.22-8.osg                           lcmaps-plugins-verify-proxy.x86_64 0:1.4.9-3.osg                         
  lfc.x86_64 0:1.8.2-1.el5                                                   lfc-libs.x86_64 0:1.8.2-1.el5                                            
  lfc-python.x86_64 0:1.8.2-1.el5                                            log4j.x86_64 0:1.2.13-3jpp.2                                             
  mx4j.x86_64 1:3.0.1-6jpp.4                                                 myproxy.x86_64 0:5.6-2.osg                                               
  myproxy-libs.x86_64 0:5.6-2.osg                                            ndt.x86_64 0:3.6.4-1.osg                                                 
  netlogger.noarch 0:4.2.0-1                                                 nmap.x86_64 2:4.11-1.1                                                   
  osg-ce.x86_64 0:3.0.0-24                                                   osg-client.noarch 0:3.0.0-14                                             
  osg-configure.noarch 0:0.7.1-1.osg                                         osg-configure-ce.noarch 0:0.7.1-1.osg                                    
  osg-configure-cemon.noarch 0:0.7.1-1.osg                                   osg-configure-gip.noarch 0:0.7.1-1.osg                                   
  osg-configure-gratia.noarch 0:0.7.1-1.osg                                  osg-configure-managedfork.noarch 0:0.7.1-1.osg                           
  osg-configure-misc.noarch 0:0.7.1-1.osg                                    osg-configure-sge.noarch 0:0.7.1-1.osg                                   
  osg-configure-squid.noarch 0:0.7.1-1.osg                                   osg-discovery.noarch 0:1.0.7-3                                           
  osg-info-services.noarch 0:0.9-1                                           osg-site-verify.noarch 0:3.0.0-1.osg                                     
  osg-site-web-page.noarch 0:0.15-3                                          osg-system-profiler.noarch 0:0.0.4-1.osg                                 
  osg-version.noarch 0:3.0.5-1                                               osg-vo-map.noarch 0:0.0.1-1.osg                                          
  osg-wn-client.noarch 0:3.0.0-13                                            owamp-client.x86_64 0:3.2rc4-1                                           
  perl-Convert-ASN1.noarch 0:0.20-1.1                                        perl-Crypt-SSLeay.x86_64 0:0.51-11.el5                                   
  perl-HTML-Parser.x86_64 0:3.55-1.fc6                                       perl-HTML-Tagset.noarch 0:3.10-2.1.1                                     
  perl-IO-Socket-SSL.noarch 0:1.01-1.fc6                                     perl-LDAP.noarch 1:0.33-3.fc6                                            
  perl-Net-SSLeay.x86_64 0:1.30-4.fc6                                        perl-TermReadKey.x86_64 0:2.30-4.el5                                     
  perl-libwww-perl.noarch 0:5.805-1.1.1                                      pyOpenSSL.x86_64 0:0.6-2.el5                                             
  regexp.x86_64 0:1.4-2jpp.2                                                 saml2-xacml2-c-lib.x86_64 0:1.0.1-7.osg                                  
  tomcat5.x86_64 0:5.5.23-0jpp.19.el5_6                                      tomcat5-common-lib.x86_64 0:5.5.23-0jpp.19.el5_6                         
  tomcat5-jasper.x86_64 0:5.5.23-0jpp.19.el5_6                               tomcat5-jsp-2.0-api.x86_64 0:5.5.23-0jpp.19.el5_6                        
  tomcat5-server-lib.x86_64 0:5.5.23-0jpp.19.el5_6                           tomcat5-servlet-2.4-api.x86_64 0:5.5.23-0jpp.19.el5_6                    
  uberftp.x86_64 0:2.6-3.osg                                                 vo-client.noarch 0:40-2.osg                                              
  vo-client-edgmkgridmap.noarch 0:40-2.osg                                   voms.x86_64 0:2.0.6-5.osg                                                
  voms-clients.x86_64 0:2.0.6-5.osg                                          wsdl4j.x86_64 0:1.5.2-4jpp.1                                             
  xalan-j2.noarch 0:2.7.0-10.osg                                             xerces-j2.x86_64 0:2.7.1-7jpp.2.el5_4.2                                  
  xml-commons.x86_64 0:1.3.02-0.b2.7jpp.10                                   xml-commons-apis.x86_64 0:1.3.02-0.b2.7jpp.10                            
  xml-commons-resolver.x86_64 0:1.1-1jpp.12                                 

Dependency Updated:
  jdk.x86_64 2000:1.6.0_29-fcs.1.osg                                                                                                                   

Complete!


That all took about 3 minutes!


February 1, 2012

OSG Post Install Configuration

All the configuration options for OSG are now located in /etc/osg/config.d. I will include the changes made to each file. If not listed then assume to accept the default values in each .ini file parameter.

These are the files I used for a ROCKS frontend. Any hostname variables will need to be changed to meet your needs.

01-squid.ini

;===================================================================
;                             Squid
;===================================================================

[Squid]
; Set the enabled setting to True if you have squid installed and wish to 
; use it, otherwise set it to False 
enabled = FALSE

; If you are using squid, specify the location of the squid server in the 
; location setting, this should be an url
location = DEFAULT

; If you are using squid, use the policy setting to indicate which cache
; replacement policy squid is using
policy = DEFAULT

; If you are using squid, use the cache_size setting to indicate which the 
; size of the disk cache that squid is using
cache_size = DEFAULT

; If you are using squid, use the memory_size setting to indicate which the 
; size of the memory cache that squid is using
memory_size = DEFAULT

10-misc.ini

;===================================================================
;                              Misc Services
;===================================================================


[Misc Services]
; If you have glexec installed on your worker nodes, enter the location
; of the glexec binary in this setting
glexec_location = UNAVAILABLE


; This setting should be set to the host used for gums host.  
; If your site is not using a gums host, you can set this to DEFAULT
gums_host = DEFAULT

; This setting should be set to one of the following: gridmap, xacml
; to indicate whether gridmap files or  gums with xacml should be used
authorization_method = gridmap

; As of OSG 3.0.4 cleanup scripts are not included in the current rpms
; so the following settings can be left commented out for now
; For more information on the cleanup scripts see the Twiki:
;   https://twiki.grid.iu.edu/bin/view/ReleaseDocumentation/VdtCleanupScripts
; Defaults to disabled
;enable_cleanup = FALSE

; The age in days after which files that have not been accessed should be 
; deleted. Jobs that run longer than this number of days may be killed because
; necessary files in VDT_LOCATION/globus/tmp may be removed.  If this is a 
; problem for you do not run the vdt-cleanup script and email 
; vdt-support@opensciencegrid.org
; Default = 14
;cleanup_age_in_days = 14

; The user's home directories that should be cleaned up.  The default value
; is @vo-file.  This will open osg-user-vo-map.txt and try to get the list
; of users from this file.  Alternatively you can specify a whitespace 
; separated list of users.
;cleanup_users_list = @vo-file

; The cron time at which the cleanup script will run.  By default it will run
; once a day during the night.
;cleanup_cron_time = 15 1 * * *

10-storage.ini

*For this ini file I created an /osg directory and all the subdirectories referenced in the file and shared it out over NFS to the internal ROCKS network so client Compute Nodes can reach.

;===================================================================
;                            Storage 
;===================================================================

[Storage]
;
; Several of these values are constrained and need to be set in a way
; that is consistent with one of the OSG storage models
;
; Please refer to the OSG release documentation for an indepth explanation 
; of the various storage models and the requirements for them

; If you have a SE available for your cluster and wish to make it available 
; to incoming jobs, set se_available to True, otherwise set it to False
se_available = FALSE

; If you indicated that you have an se available at your cluster, set default_se to
; the hostname of this SE, otherwise set default_se to UNAVAILABLE
default_se = UNAVAILABLE

; The grid_dir setting should point to the directory which holds the files 
; from the OSG worker node package, it should be visible on all of the computer
; nodes (read access is required, worker nodes don't need to be able to write) 
; 
; For RPM installations, /etc/osg/wn-client is the correct location
grid_dir = /etc/osg/wn-client/

; The app_dir setting should point to the directory which contains the VO 
; specific applications, this should be visible on both the CE and worker nodes
; but only the CE needs to have write access to this directory
; 
; YOU WILL NEED TO CHANGE THIS
app_dir = /osg/apps

; The data_dir setting should point to a directory that can be used to store 
; and stage data in and out of the cluster.  This directory should be readable
; and writable on both the CE and worker nodes
; 
; YOU WILL NEED TO CHANGE THIS
data_dir = /osg/data

; The worker_node_temp directory should point to a directory that can be used 
; as scratch space on compute nodes, it should allow read and write access on the 
; worker nodes but can be local to each worker node
; 
; YOU WILL NEED TO CHANGE THIS
worker_node_temp = /osg/scratch

; The site_read setting should be the location or url to a directory that can 
; be read to stage in data, this is an url if you are using a SE 
; 
; YOU WILL NEED TO CHANGE THIS
site_read = /osg/stage_in

; The site_write setting should be the location or url to a directory that can 
; be write to stage out data, this is an url if you are using a SE 
; 
; YOU WILL NEED TO CHANGE THIS
site_write = /osg/stage_out

15-managedfork.ini

;===================================================================
;                              Managed Fork
;===================================================================


[Managed Fork]
; The enabled setting indicates whether managed fork is in use on the system
; or not. You should set this to True or False
enabled = FALSE

20-sge.ini

;===================================================================
;                              SGE
;===================================================================


[SGE]
; This section has settings for configuring your CE for a SGE job manager

; The enabled setting indicates whether you want your CE to use a SGE job 
; manager
; valid answers are True or False
enabled = TRUE

; The sge_root setting should give the location of sge install directory
;
sge_root = /opt/gridengine

; The sge_cell setting should be set to the value of $SGE_CELL for your SGE
; install.
sge_cell = /opt/gridengine/default

; The job_contact setting should give the contact string for the jobmanager 
; on this CE (e.g. host.name/jobmanager-sge) 
job_contact = rocksvmfe.uabgrid.uab.edu/jobmanager-sge

; The util_contact should give the contact string for the default jobmanager
; on this CE (e.g. host.name/jobmanager)
util_contact = rocksvmfe.uabgrid.uab.edu/jobmanager

30-cemon.ini

;===================================================================
;                         CEMon
;===================================================================

[Cemon]

; Default servers for production and itb OSG ress/bdii servers, please don't touch

; The current production osg servers
; Production ReSS server
osg-ress-servers = https://osg-ress-1.fnal.gov:8443/ig/services/CEInfoCollector[OLD_CLASSAD]
; Production BDII server
osg-bdii-servers = http://is1.grid.iu.edu:14001[RAW], http://is2.grid.iu.edu:14001[RAW]

; The current itb osg servers
; ITB ReSS server
itb-ress-servers = https://osg-ress-4.fnal.gov:8443/ig/services/CEInfoCollector[OLD_CLASSAD]
; ITB BDII server
itb-bdii-servers = http://is1.grid.iu.edu:14001[RAW], http://is2.grid.iu.edu:14001[RAW]
 

; The enable option indicates whether cemon should be enabled or 
; disabled.  It should be set to True or False
;
; You generally want Cemon enabled for any CE installation
enabled = TRUE

; This setting indicates which servers ress information should
; be sent to.  Most sites should use the %(osg-ress-servers)s 
; setting so that the predefined variable giving the default
; osg production servers will be used, ITB admins can use 
; %(itb-ress-servers)s for default itb servers
;
; The server list should be formated as follows:
; server_uri[format],server_uri[format]
; see the variables at the top of this section for examples of this 
ress_servers = DEFAULT

; This setting indicates which servers bdii information should
; be sent to.  Most sites should use the %(osg-bdii-servers)s 
; setting so that the predefined variable giving the default
; osg production servers will be used, ITB admins can use 
; %(itb-bdii-servers)s for default itb servers
; 
; The formatting for this are the same as the ress_servers setting 
bdii_servers = DEFAULT

30-gip.ini *You must define at least one subcluster even if you only have the one ROCKS cluster. SE was left unconfigured as we are not running a Storage Element.

;===================================================================
;                              GIP
;===================================================================

[GIP]

; ========= These settings must be changed ==============

;; This setting indicates the batch system that GIP should query
;; and advertise
;; This should be the name of the batch system in lowercase
batch = sge
;; Options include: pbs, lsf, sge, or condor

; ========= These settings can be left as is for the standard install ========

;; This setting indicates whether GIP should advertise a gsiftp server
;; in addition to a srm server, if you don't have a srm server, this should
;; be enabled
;; Valid options are True or False
advertise_gsiftp = TRUE

;; This should be the hostname of the gsiftp server that gip will advertise
gsiftp_host = DEFAULT

;; This setting indicates whether GIP should query the gums server.
;; Valid options are True or False
advertise_gums = FALSE


;===================================================================
;                          Subclusters
;===================================================================

; For each subcluster, add a new subcluster section.
; Each subcluster name must be unique for the entire grid, so make sure to not
; pick anything generic like "MAIN".  Each subcluster section must start with
; the words "Subcluster", and cannot be named "CHANGEME".

; There should be one subcluster section per set of homogeneous nodes in the
; cluster.

; This data is used for our statistics collections in the OSG, so it's important
; to keep it up to date.  This is important for WLCG sites as it will be used
; to determine your progress toward your MoU commitments!

; If you have many similar subclusters, then feel free to collapse them into
; larger, approximately-correct groups.

; See example below:

[Subcluster rocksvm]
; should be the name of the subcluster
name = ROCKSVMFE
; number of homogeneous nodes in the subcluster
node_count = 2
; Megabytes of RAM per node.
ram_mb = 1024
; CPU model, as taken from /proc/cpuinfo.  Please, no abbreviations!
cpu_model = Intel Core i7 CPU 870  @ 2.93GHz
; Should be something like:
; cpu_model = Dual-Core AMD Opteron(tm) Processor 2216
; Vendor's name -- AMD or Intel?
cpu_vendor = INTEL
; Approximate speed, in MHZ, of the chips
cpu_speed_mhz = 2930 
; Must be an integer.  Example: cpu_speed_mhz = 2400
; Platform; x86_64 or i686
cpu_platform = x86_64

; Number of CPUs (physical chips) per node
cpus_per_node = 1
; Number of cores per node.
cores_per_node = 2
; For a dual-socket quad-core, you would put cpus_per_node=2 and
; cores_per_node=8

; Set to true or false depending on inbound connectivity.  That is, external
; hosts can contact the worker nodes in this subcluster based on their hostname.
inbound_network = FALSE
; Set to true or false depending on outbound connectivity.  Set to true if the
; worker nodes in this subcluster can communicate with the external internet.
outbound_network = TRUE

; Non-mandatory attributes
; The amount of swap per host in MB
;  swap_mb = 4000
; The per-core SpecInt 2000 score.  This is usually computed for you.
;  SI00 = 2000
; The per-core SpecFloat 2000 score.  This is usually computed for you
;  SF00 = 2000

; Mandatory for WLCG reporting
; The per-core HEPSPEC score.  See your VO representative for more information.
;  HEPSPEC = 8
; The conversion factor from HEPSPEC to SI2K is accepted to be 250.

; Here's a full example.  Remember, globally unique names!
; [Subcluster Dell Nodes UNL]
; name = Dell Nodes UNL
; node_count = 53
; ram_mb = 4110
; swap_mb = 4000
; cpu_model = Dual-Core AMD Opteron(tm) Processor 2216
; cpu_vendor = AMD
; cpu_speed_mhz = 2400
; cpus_per_node = 2
; cores_per_node = 4
; inbound_network = FALSE
; outbound_network = TRUE


;===================================================================
;                             SE
;===================================================================

; For each storage element, add a new SE section.
; Each SE name must be unique for the entire grid, so make sure to not
; pick anything generic like "MAIN".  Each SE section must start with
; the words "SE", and cannot be named "CHANGEME".

; There are two main configuration types; one for dCache, one for BestMan

; Don't forget to change the section name!  One section per SE at the site.
[SE CHANGEME]

; The first part of this section shows options which are mandatory for all SEs.
; dCache and BestMan-specific portions are shown afterward.

; Set to False to turn off this SE
enabled = False

; Name of the SE; set to be the same as the OIM registered name
name = SE_CHANGEME
; The endpoint of the SE.  It MUST have the hostname, port, and the server
; location (/srm/v2/server in this case).  It MUST NOT have the ?SFN= string.
srm_endpoint = httpg://srm.example.com:8443/srm/v2/server
; dCache endpoint template: httpg://srm.example.com:8443/srm/managerv2

; How to collect data; the most generic implementation is called "static"
provider_implementation = static
; WLCG sites with a SE *must* use bestman, dcache, or dcache19
; Implementation and version of your SRM SE; usually dcache or bestman
implementation = bestman
; Version refers to the SE version, not the SRM version.
version = 2.2.1.foo
; dCache example: version = 1.9.1
; Default paths for all of your VOs; VONAME is replaced with the VO's name.
default_path = /mnt/bestman/home/VONAME
; Set a specific path for VOs which don't use the default path.
; Comma-separated list of VO:PATH pairs.  Not required.
; vo_dirs=cms:/mnt/bestman/cms, dzero:/mnt/bestman2/atlas

; If your SE provides a POSIX-like mount on your worker nodes, uncomment
; the following line:
; mount_point = /,/
; POSIX-like file systems include Lustre, NFS, HDFS, xrootdfs
; dCache site should not uncomment the line
; The value of `mount_point` should be two paths; first, the path where the
; file system is mounted on the worker nodes, followed by the exported directory
; of the file system.  If you mount your file system on the worker nodes with
; the following command:
;    mount -t nfs nfs.example.com:/exported/dir /mnt/nfs
; then mount_point should look like this:
;    mount_point = /mnt/nfs,/exported/dir

; By default, all VOs are advertised as having access to your SE. If you want only a subset of 
; VOs to be advertised, list them as a comma separated list in the allowed_vos setting 
; allowed_vos = 

; For BestMan-based SEs, uncomment and fill in the following.
;  provider_implementation = bestman
;  implementation = bestman

; Set to TRUE if the bestman provide can use 'df' on the directory referenced
; above to get the freespace information.  If set to false, it probably won't
; detect the correct info.
;  use_df = True

; For dCache-based SEs, uncomment and fill in the following
; How to collect data; set to 'dcache' for dcache 1.8 (additional config req'd
; for this case), 'dcache19' for dcache 1.9, or 'static' for default values.
; provider_implementation = dcache19
;  implementation = dcache
;  If you use the dcache provider, see 
; http://twiki.grid.iu.edu/bin/view/InformationServices/DcacheGip
; If you use the dcache19 provider, you must fill in the location of your
; dCache's information provider:
;  infoprovider_endpoint = http://dcache.example.com:2288/info
; SE implementation name; leave as 'dcache'

; Here are working configs for BestMan and dCache
; [SE dCache]
; name = T2_Nebraska_Storage
; srm_endpoint = httpg://srm.unl.edu:8443/srm/managerv2
; provider_implementation = static
; implementation = dcache
; version = 1.8.0-15p6
; default_path = /pnfs/unl.edu/data4/VONAME

; [SE Hadoop]
; name = T2_Nebraska_Hadoop
; srm_endpoint = httpg://dcache07.unl.edu:8443/srm/v2/server
; provider_implementation = bestman
; implementation = bestman
; version = 2.2.1.2.e1
; default_path = /user/VONAME

30-gratia.ini

;===================================================================
;                         Gratia
;===================================================================

[Gratia]

; Default gratia servers
; 
; Please don't change these unless you have good reason to do so

; Variables for osg itb probes, CE installations should use the 
; jobmanager probe
itb-jobmanager-gratia = jobmanager:gratia-osg-itb.opensciencegrid.org:80
itb-gridftp-gratia = gridftp:gratia-osg-itb.opensciencegrid.org:80


; Variables for osg production probes, CE installations should use the 
; jobmanager probe
osg-jobmanager-gratia = jobmanager:gratia-osg-prod.opensciencegrid.org:80
osg-gridftp-gratia = gridftp:gratia-osg-transfer.opensciencegrid.org:80
    

; The enable option indicates whether gratia should be enabled or 
; disabled.  It should be set to True or False
;
; You generally want Gratia enabled for any CE installation, in 
; addition SE installations may want to enable gratia to use 
; the gratia gridftp reporting
enabled = TRUE


; This setting specifies the resource that gratia will use to report
; accounting information, on a CE if you leave this blank, gratia will
; use the resource setting from the Site Information section
;
resource = DEFAULT

; This setting indicates which probes should be enabled for gratia
; The list should be given as probe_name1:host1:port1, probe_name2:host2:port2 
; where probe_name is either jobmanager or gridftp
; host is a fully qualified domain name
; port is the port that the server is listening on
; CEs should have entries for jobmanager probe
; SEs should use gridftp if they would like to enable gridftp transfer
; accounting 
;
; for convenience admins can use %(osg-jobmanager-gratia)s, and
; %(osg-gridftp-gratia)s for production sites
; and %(itb-jobmanager-gratia)s, and %(itb-gridftp-gratia)s for ITB sites
probes = DEFAULT

40-localsettings.ini *left blank

;
; Put any environment variables that should go into the local
; job environment for grid jobs here.  The format is
;   env = setting
; and case is preserved, the setting does not need to be quoted
; See https://twiki.grid.iu.edu/bin/view/Documentation/Release3/IniConfigurationOptions#Local_Settings
; for more details
[Local Settings]


40-network.ini *created source and port state files below with touch command. not sure if necessary. port ranges may need modification based on your firewall needs.

;===================================================================
;                              Network
;===================================================================

[Network]
; For more discussion on what other things may need to be set to work 
; with the globus_source_range and globus_port_range, see
; https://twiki.grid.iu.edu/bin/view/Documentation/Release3/FirewallInformation

; This setting should give the low port and high port for a contiguous range
; of ports that inbound connections to globus may arrive on
; the range should be given as low_port,high_port (e.g. 2048,4096)  
source_range = 45000,45999

; This setting should give the location of the file that globus should
; use to track inbound port usage 
source_state_file =  /osg/globus_incoming

; This setting should give the low port and high port for a contiguous range
; of ports that outbound connections from globus should use
; the range should be given as low_port,high_port (e.g. 2048,4096)  
port_range = 45000,45999


; This setting should give the location of the file that globus should
; use to track outbound port usage 
port_state_file = /osg/globus_outgoing

40-siteinfo.ini *this file will need the most customization.This is what is advertised out to the grid for VO, sponsor, location, contact, etc. You will need to be setup @OIM first for the values to valid.

;===================================================================
;                       Site Information
;===================================================================

[Site Information]
; The group option indicates the group that the OSG site should be listed in,
; for production sites this should be OSG, for vtb or itb testing it should be
; OSG-ITB
; 
; YOU WILL NEED TO CHANGE THIS
group = OSG

; The host_name setting should give the host name of the CE  that is being 
; configured, this setting must be a valid dns name that resolves
; 
; YOU WILL NEED TO CHANGE THIS
host_name = rocksvmfe.uabgrid.uab.edu

; The resource setting should be set to the same value as used in the OIM 
; registration at the goc 
; 
; YOU WILL NEED TO CHANGE THIS
resource = UAB Research Computing


; The resource_group setting should be set to the same value as used in the OIM 
; registration at the goc 
; 
; YOU WILL NEED TO CHANGE THIS
resource_group = Advanced Technology Lab

; The sponsor setting should list the sponsors for your cluster, if your cluster
; has multiple sponsors, you can separate them using commas or specify the 
; percentage using the following format 'osg, atlas, cms' or 
; 'osg:10, atlas:45, cms:45'  
; 
; YOU WILL NEED TO CHANGE THIS
sponsor =  SURAGrid

; The site_policy setting should give an url that lists your site's usage
; policy 
site_policy = http://docs.uabgrid.uab.edu

; The contact setting should give the name of the admin/technical contact
; for the cluster
; 
; YOU WILL NEED TO CHANGE THIS
contact = William M Bradley

; The email setting should give the email address for the technical contact
; for the cluster 
; 
; YOU WILL NEED TO CHANGE THIS
email = billb@uab.edu

; The city setting should give the city that the cluster is located in
; 
; YOU WILL NEED TO CHANGE THIS
city = Birmingham

; The country setting should give the country that the cluster is located in
; 
; YOU WILL NEED TO CHANGE THIS
country = US

; The longitude setting should give the longitude for the cluster's location
; if you are in the US, this should be negative
; accepted values are between -180 and 180
; 
; YOU WILL NEED TO CHANGE THIS
longitude = 33.57 

; The latitude setting should give the latitude for the cluster's location
; accepted values are between -90 and 90
; 
; YOU WILL NEED TO CHANGE THIS
latitude = 86.75

Once all files are edited and in place then run:

osg-configure -v

and check for any syntax errors.

Sun Grid Engine Initialization

The SGE needs to have at least one job submitted to ensure all of the proper log files/directories are created. I followed the directions from RocksClusters.org. Basically I created a qsub job script that runs the unix date command twice with a sleep in between and then submitted it to grid.

[root@rocksvmfe ~]# cat sleep.sh 
#$ -j y
#$ -S /bin/bash
#
date
sleep 10
date

Then you submit it with the qsub command.

[root@rocksvmfe ~]# qsub sleep.sh
your job 16 ("sleep.sh") has been submitted

That is all you need to do for the grid engine.


February 12, 2012

Post Install Configuration

  1. Fetch the latest CRL list

this process may take a while on the first run so get a coffee

[root@rocksvmfe ~]$ fetch-crl   # This fetches the CRLs 
[root@rocksvmfe ~]$ /sbin/service fetch-crl-boot start
[root@rocksvmfe ~]$ /sbin/service fetch-crl-cron start
  1. Start edg-mkgridmap for authorization

GUMS is not yet recommended for RPM installs so i used gridmap

[root@rocksvmfe ~]$ /sbin/service edg-mkgridmap start

This populates the grid map file with static VO information

  1. Start Globus Gatekeeper
    [root@rocksvmfe ~]$ /sbin/service globus-gatekeeper start
    
  1. Start GridFTP
    [root@rocksvmfe ~]$ /sbin/service globus-gridftp server start
    
  1. Start Tomcat
    [root@rocksvmfe ~]$ /sbin/service tomcat5 start
    

We ran into difficulties with this step as the service tomcat5 start command would hang up and not complete tomcat initialization. It was determined that the tomcat-webapps package was not installled as a depedndency. All of the tomcat packages were pulled from upstream Centos repos during install. Once we installed tomcat-webapps the service started as excepcted.

Setup Services to Start on Boot

To setup the serivces so that they start with subsequent reboots, I ran the following commands:

[root@rocksvmfe ~]$ /sbin/chkconfig fetch-crl-boot on
[root@rocksvmfe ~]$ /sbin/chkconfig fetch-crl-cron on
[root@rocksvmfe ~]$ /sbin/chkconfig edg-mkgridmap on
[root@rocksvmfe ~]$ /sbin/chkconfig globus-gatekeeper on
[root@rocksvmfe ~]$ /sbin/chkconfig globus-gridftp-server on
[root@rocksvmfe ~]$ /sbin/chkconfig tomcat5 on

Validating Compute Element

After installing OSG stack, certs and configuring, it is time to Validate and Test the install. Following Instructions from OSG.

1) Add your personal CERT to system in .pem and .p12 formats

  • I used my DOEGids personal cert. The cert contains the user cert and the private key. You have to use the openssl command to extract cert and keys to the proper format. From Keychain in OSX I just selected both my personal cert and the key and exported as UserCert?.p12. Then ran the following commands on the ROCKS fe.
openssl pkcs12 -nocerts -in UserCerts.p12 -out userkey.pem
openssl pkcs12 -clcerts -nokeys -in UserCerts.p12 -out usercert.pem

Set files persmissions on userkey.pem to 600 for security or you will get nagged by grid-proxy-init.

2) Validate Authentication

-Start Grid or VOMS proxy

For our purposes I used a grid proxy instead of voms. Its important to do this as regular user...not root. If you need to create a new user with useradd and copy personal cert/key files over and then start a grid-proxy for testing like so:

grid-proxy-init -cert usercert.pem -key userkey.pem
Your identity: /DC=org/DC=doegrids/OU=People/CN=WIlliam M Bradley 150085
Enter GRID pass phrase for this identity:
Creating proxy .......................................................... Done
Your proxy is valid until: Fri Feb 17 23:02:31 201

-Notice my identity string "/DC=org/DC=doegrids/OU=People/CN=WIlliam M Bradley 150085". This comes from the user cert and will be unique to your own cert when you are setting up. This need to be added to the local gridmap-file so you can authenticate to your own cluster for test purposes. So in /etc/grid-security/grid-mapfile you need the following:

" /DC=org/DC=doegrids/OU=People/CN=John Q Public 666666" userid

Obviously the CN will be unique to your personal cert name and the userid is the unix local account you create and are logged in as (not root!). Quotes around identity string are needed btw.

-Submit Job

As the same user as above run:

globusrun -a -r rocksvmfe.uabgrid.uab.edu

You should see:

[billb@rocksvmfe ~]$ globusrun -a -r rocksvmfe.uabgrid.uab.edu

GRAM Authentication test successful

SUCCESS! *Note it was from failing this step I figured out how to add the proper identity to the grid-mapfile and not to run as root.

3) Validate you can run a job

  • Run a job against your CE local job manager (fork)
    [billb@rocksvmfe ~]$ globus-job-run rocksvmfe.uabgrid.uab.edu /bin/hostname
    rocksvmfe.uabgrid.uab.edu
    

-Submit job to your CE batch system. ROCKS uses SGE but you can substitute Condor, PBS, LSF

[billb@rocksvmfe ~]$ globus-job-run rocksvmfe.uabgrid.uab.edu/jobmanager-sge /bin/hostname
GRAM Job failed because the job manager detected an invalid script response (error code 24)
Details: qsub failed: \nerror: could not get environment variable SGE_QMASTER_PORT or service "sge_qmaster"\n
[billb@rocksvmfe ~]$ 

It appears as if something is wrong with either my configuration in OSG or SGE. However I can submit with qsub so I think it must be with globus/osg config. WIll investigate further. UPDATE - The fix for this was to edit the /etc/services file. Apparently Globus-Gram is checking it for SGE_QMASTER_PORT number

sge_qmaster    536/tcp                         # sge_qmaster
sge_execd        537/tcp                         # sge_execd

With rocks you will have to either comment out the current entries or delete them.

4) Validate File transfers

  • Copy to:
globus-url-copy file:///proc/cpuinfo gsiftp://rocksvmfe.uabgrid.uab.edu/tmp/cpuinfo-del

*Exits silently is good Verify

[billb@rocksvmfe ~]$ cat /tmp/cpuinfo-del 
processor	: 0
vendor_id	: GenuineIntel
cpu family	: 6
model		: 30
model name	: Intel(R) Core(TM) i7 CPU         870  @ 2.93GHz
stepping	: 5
cpu MHz		: 2925.800
cache size	: 8192 KB
fpu		: yes
fpu_exception	: yes
cpuid level	: 11
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss syscall nx rdtscp lm constant_tsc up ida nonstop_tsc pni ssse3 cx16 sse4_1 sse4_2 popcnt lahf_lm
bogomips	: 5851.60
clflush size	: 64
cache_alignment	: 64
address sizes	: 40 bits physical, 48 bits virtual
power management: [8]

-Copy from:

billb@rocksvmfe ~]$ globus-url-copy gsiftp://rocksvmfe.uabgrid.uab.edu/proc/version file:///tmp/version-deletme

Verify

[billb@rocksvmfe ~]$ cat /tmp/version-deletme 
Linux version 2.6.18-274.el5 (mockbuild@builder10.centos.org) (gcc version 4.1.2 20080704 (Red Hat 4.1.2-50)) #1 SMP Fri Jul 22 04:43:29 EDT 2011